1

I'm hoping someone can help me with this because after 2 days of googling I've come up with nothing.

I have a file server that I have converted from a physical to a virtual on an ESXi 6 host. I have increased the disk size in ESXi by 400GB's, and in windows I can see the unallocated space, however when i try to extend a partition or create a new one I receive the error:

"There is not enough space available on the disk(s) to complete this operation"

Initially the disk was basic so I converted it to dynamic thinking this could be the problem (even though I've increased basic disks before), and I still got the same error message.

I read that this issue is sometimes caused by there not being enough space at the end of the disk, and shrinking the volume by 100MB can resolve it, I did this and another section of unallocated space appeared in disk manager, in which I can create a new volume of 100MBs or extend the partition back by 100MB.

For some reason, the unallocated 400GB is completely unusable and I don't know why.

Screenshot of Disk Management and error message:

Image description

Screenshot of partitions in DISKPART:

Image description

Any help would be greatly appreciated.

P.S I have tried a rescan as 90% of webpages told me to do, to no avail.

  • What's that 90MB of unallocated space? If you delete the 100MB volume does Disk Management still show the 90MB of unallocated space and the 402.05GB of unallocated space? – joeqwerty May 15 '16 at 16:23
  • The 90mb is the result of me shrinking the D volume by 100mb and increasing it again by 10mb as a test. – Ben Watkins May 15 '16 at 20:51
  • 1
    Did you reboot? – ewwhite May 15 '16 at 21:50
  • Those two reserved partitions at the 1133GB mark look like a problem (don't touch them!). I created a test disk in a VM and my "Dynamic Reserved" and reserved are at the front of the disk. The 17KB offset seems to indicate your disk is partitioned GPT, which seems to affect how/what partitions get created w/ a Dynamic disk. I think the dynamic disk wants its "Dynamic Data" partition to be one big, uninterrupted partition, and unfortunately since the reserved partitions are at the end, not the beginning, any operation to expand it is failing - that's my guess to why... – Joshua McKinnon May 16 '16 at 1:24
0

It sounds like the unallocated space is not available to be added to your disk, due to logical alignment issue (space before, or preceeding). You can use Gparted to change the alignment of the free space, and make it availbale to your desired drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.