2

supervisorctl says that gunicorn procces have a RUNNING state and I thought that it is success. But something is wrong yet. Resource available only by IP

Nginx config:

upstream hello_app_server {
  server unix:/var/www/aqe-backend/gunicorn.sock fail_timeout=0;
}

server {

    listen   80;
    server_name 188.166.200.51;

    client_max_body_size 4G;

    access_log /var/www/aqe-backend/logs/nginx-access.log;
    error_log /var/www/aqe-backend/logs/nginx-error.log;

    location /static/ {
        alias   /var/www/aqe-backend/static/;
    }

    location /media/ {
        alias   /var/www/aqe-backend/media/;
    }

    location / {
        # an HTTP header important enough to have its own Wikipedia entry:
        #   http://en.wikipedia.org/wiki/X-Forwarded-For
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

        # enable this if and only if you use HTTPS, this helps Rack
        # set the proper protocol for doing redirects:
        # proxy_set_header X-Forwarded-Proto https;

        # pass the Host: header from the client right along so redirects
        # can be set properly within the Rack application
        proxy_set_header Host $http_host;

        # we don't want nginx trying to do something clever with
        # redirects, we set the Host: header above already.
        proxy_redirect off;

        # set "proxy_buffering off" *only* for Rainbows! when doing
        # Comet/long-poll stuff.  It's also safe to set if you're
        # using only serving fast clients with Unicorn + nginx.
        # Otherwise you _want_ nginx to buffer responses to slow
        # clients, really.
        # proxy_buffering off;

        # Try to serve static files from nginx, no point in making an
        # *application* server like Unicorn/Rainbows! serve static files.
        if (!-f $request_filename) {
            proxy_pass http://188.166.200.51;
            break;
        }
    }

    error_page 500 502 503 504 /500.html;
    location = /500.html {
        root /var/www/aqe-backend/static/;
    }
}

gunicorn script:

#!/bin/bash

NAME="aqe"                                  # Name of the application
DJANGODIR=/var/www/aqe-backend/             # Django project directory
SOCKFILE=/var/www/aqe-backend/gunicorn.sock  # we will communicte using this unix socket
USER=www-data                                        # the user to run as
GROUP=www-data                                     # the group to run as
NUM_WORKERS=3                                     # how many worker processes should Gunicorn spawn
DJANGO_SETTINGS_MODULE=project.settings_prod             # which settings file should Django use
DJANGO_WSGI_MODULE=project.wsgi                     # WSGI module name

echo "Starting $NAME as `whoami`"

# Activate the virtual environment
cd $DJANGODIR
source env/bin/activate
export DJANGO_SETTINGS_MODULE=$DJANGO_SETTINGS_MODULE
export PYTHONPATH=$DJANGODIR:$PYTHONPATH

# Create the run directory if it doesn't exist
RUNDIR=$(dirname $SOCKFILE)
test -d $RUNDIR || mkdir -p $RUNDIR

# Start your Django Unicorn
# Programs meant to be run under supervisor should not daemonize themselves (do not use --daemon)
exec gunicorn ${DJANGO_WSGI_MODULE}:application \
  --name $NAME \
  --workers $NUM_WORKERS \
  --user=$USER --group=$GROUP \
  --bind=unix:$SOCKFILE \
  --log-level=debug \
  --log-file=-
| improve this question | | | | |
  • What happens when you proxy_pass to HTTP://hello_app_server instead of the webserver? – AWippler May 16 '16 at 2:52
0

Try checking if your gunicorn.sock file is really there. It could be that the folder in which it should be in does not have the right permissions, or does not exist at all (it probably won't if you just followed a tutorial).

Remove it if it already exists, and (re)create it with mkdir /var/www/aqe-backend.

See https://stackoverflow.com/questions/28689445/nginx-django-and-gunicorn-gunicorn-sock-file-is-missing for more info.

Also checking the logs, like in tail /var/log/long.err.log can help.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.