I'm getting a php data upload fail when attempting to transfer data up to a mysql database from a html5/webgl built app off of Unity. All of the data downloads work regardless of the upload issue. The upload issue happens after an indeterminable amount of time.

The only error I'm seeing anywhere is : A fatal alert was generated and sent to the remote endpoint. This may result in termination of the connection. The TLS protocol defined fatal error code is 10. The Windows SChannel error state is 1203.

This is only happening when the server is booted up however. The server is an EC2 Amazon m4 large. No errors can be found for each attempt to post data to the mysql database. The downloads can be seen being pulled in the cpu usage and then upload fails afterwards.

This has happened once before, there was a full mysql reinstall, base reload of the table/schema and the problem persisted. Wiped the VM, did an identical install, and everything worked great until the same problem suddenly happened.

I'm leaning towards some time out limit, blocking, or other that has occurred but have been unable to locate any issue.

Any help is appreciated.

  • what size is the data you are trying to upload and what are the values of upload_max_filesize and post_max_size in php.ini – Sum1sAdmin May 16 '16 at 10:34
  • A string about 120 bytes long. There are a lot of php access requests but we had 12 clients hitting it repeatedly and using the server side app at the same time for about four hours. Stopped for an hour and did it again. No problems. Then we waited for a partner of ours to finish up their package. Came back to it 4 or 5 days later. Started up the server app again to test and it choked on posting uploads to the mysql again immediately. No changes had been made the server had just been idle. – Devman85 May 21 '16 at 21:04
  • php.ini post_max_size is 8m – Devman85 May 21 '16 at 21:14

Problem was resolved. The issue was the temp directory was filling up and stopping uploads. Once the temp files were cleared up everything worked as planned. So essentially over time after letting it idle for 2-3 days the directory filled up... and there was no way a restart would resolve this issue.

Pretty surprised we didn't get any write errors or anything though.

  • Little bit more info, IIS user also did not have permissions to the temp dir which was stopping cleanup. – Devman85 May 22 '16 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.