We have an isolated network used for test and development with its own Exchange server. We've been using Windows 7 for years and have used Outlook 2007, 2010, 2012, and 2013 (which is currently being used). Exchange Server is 2013. Outlook 2013 works great in Windows 7, but we want to upgrade our development machines to Windows 10 and can't get Outlook 2013 to work. No matter what we try, we get the following error when attempting to set up an Outlook profile:

The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action.

Everything works great in Windows 7, the problem only exists on our Windows 10 workstations (haven't tried 8 or 8.1). OWA works fine, as does the built-in Windows Mail app (which uses Exchange ActiveSync). Have tried the following with no love:

  • Connected the Windows 10 workstation to the Internet and installed all available updates.
  • Installed Exchange 2013 CU 12
  • Installed the self-signed Exchange server certificate into the workstation's Trusted Root Certificates store
  • Tried specifying the domain controller's FQDN in HKCU\Software\Microsoft\Exchange\Exchange Provider "DS Server" value.
  • Verified proxy settings in Internet Options are set to automatically detect settings
  • Copied the profile stored in the Registry's HKCU\Software\Microsoft\Office\15.0\Outlook\Profiles\Outlook key from a working Windows 7 machine to a Windows 10 machine
  • Turned off firewalls on both the Exchange server and the client machine (Windows 7 boxes work fine with the firewall on)

Outlook Anywhere is configured on the Exchange server, the authentication method is set to Negotiate. I'm thinking that AutoDiscover is working because the "Add Account" dialog window reports that it can establish a network connection successfully and it seems to find the correct settings for the Microsoft Exchange dialog (the Microsoft Exchange server box shows the correct GUID for my mailbox). Again, everything works fine on our Windows 7 boxes, but we're consistently having trouble with Windows 10.

Edit: Including entries from IIS and RPC Client Access logs below.

The Windows 10 client's IP is 10.0.0.37 (IPv6 is turned off, something we do as a standard practice on our client boxes). My user name is davidsond and our domain name is MONSTERGARAGE. (I don't mind putting these details up here because this is a completely isolated test and development network with no connectivity to the Internet.)

I see entries in the Default Web Site IIS log like this:
POST /Autodiscover/Autodiscover.xml ...; 443 - 10.0.0.37 Microsoft+Office/15.0+(Windows+NT+10.0;+Microsoft+Outlook+15.0.4815;+Pro) - 401 0 0 15
POST /Autodiscover/Autodiscover.xml ...; 443 - MONSTERGARAGE\davidsond 10.0.0.37 Microsoft+Office/15.0+(Windows+NT+10.0;+Microsoft+Outlook+15.0.4815;+Pro) - 200 0 0 31

These seem to correspond to entries in the Exchange Back End IIS logs that look like this:
POST /Autodiscover/Autodiscover.xml - 444 MONSTERGARAGE\davidsond fe80::cc5b:87c5:6d04:ad7%12 Microsoft+Office/15.0+(Windows+NT+10.0;+Microsoft+Outlook+15.0.4815;+Pro) - 200 0 0 45

That IPv6 IP is our Exchange server.

The RPC Client Access log contains entries for our working Windows 7 boxes like this one:
2016-05-19T01:53:06.879Z,5,0,/o=C2LA/ou=First Administrative Group/cn=Recipients/cn=koopm,OUTLOOK.EXE,14.0.6025.1000,Cached,10.0.0.45,,fe80::cc5b:87c5:6d04:ad%12,ncacn_http...

After sifting through these and then searching for any reference to davidsond or 10.0.0.37, I realized the RPC Client Access Log had no entries whatsoever for my Windows 10 box. It seems that RPC traffic isn't reaching the Exchange server, and one of my theories is that some security setting on the Windows 10 box is preventing RPC over HTTP. I've turned off the firewall and looked in the Windows 10 Privacy settings, but didn't readily see anything I could link to RPC or Outlook.

  • What happens if you setup a manual connection, without Outlook Anywhere? You could also start Outlook with the /rpcdiag switch, it may show what servers the client is trying to connect to. – smwk May 17 '16 at 8:58
  • Thank you for the reply. Tried this with a profile I copied from a working machine, but the diagnostics window never showed any information. I get the following error: "Cannot start Microsoft Outlook. Cannot open the Outlook window. The set of folders cannot be opened. The information store could not be opened." Tried again after clearing out the profile entry in the Registry. The Add Account wizard shows, then errors with "The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action." The diagnostics window never shows. – Dave Davidson May 17 '16 at 18:26
  • What do the IIS and rpcClientAccess logs show? – smwk May 18 '16 at 14:40
  • Thank you for the suggestion - I hadn't looked in these logs yet. I will edit the question with the results. Looks like autodiscover entries exist in the IIS logs, but no entries exist in the RPC Client Access logs for the Windows 10 box. – Dave Davidson May 19 '16 at 2:04
  • There doesn't seem to be an IIS issue, what I would suggest is you get the Autodiscover settings from a working client and then try all the URLs in the browser of a Windows 10 machine, do you see any certificate errors? It only takes something small for Outlook Anywhere to not work. – smwk May 19 '16 at 8:33

I had this problem once when the Forward Lookup Zones on the Exchange server didn't have the correct DNS entries for the public domain, only the local domain. The Outlook client continued to error out and change the Proxy server connection on me. If your autoconfigure isn't correctly configured, you may also find that the authentication doesn't work properly because it defaults to the wrong format of username... eg: Email address instead of domain/username

  • Thank you very much for the reply. This is an isolated test and development network with no public domain. The only domain name is the local domain. Our Exchange server isn't a DNS server, but when I look up the DNS entries on our domain controller everything seems to be in order. The local domain is listed under Forward Lookup Zones, and entries exist for all clients and servers, to include our Exchange server. I even verified the AutoDiscover settings in Active Directory Sites and Services, it looks good. Also, all WIndows 7 boxes work great, so I'm thinking AutoDiscover is set up properly. – Dave Davidson May 17 '16 at 18:37

We had the same issues when moving from Windows 7 to Windows 10. I followed the given solutions in this Microsoft article: microsoft support - exchange connection.

After this everything worked fine again.

But take a look at AutoDiscovery as well. Even if you think it might work make sure it really does. A lot of problems with exchange have their root there.

  • Thank you for the reply. I was hesitant to try this because the only machines that work are Windows 7 machines and the broken ones are Windows 10. Copying the User Shell Folders would relocate the Cookies and Cache folders. (All other entries looked the same, and an entry for AppData was present.) I tried it anyway, with no love. The same errors occurred when running Outlook and when attempting to set up a new profile. I even restarted and tried again. Thanks, anyway. – Dave Davidson May 18 '16 at 0:27

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.