2

I've a CentOS6 server for 5 years without problems but it suddenly started throwing errors on yum update.

This is the output of yum update:

libc.so.6(GLIBC_2.14)(64bit) is needed by libdc1394-2.2.2-3.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by smp_utils-libs-0.98-3.el7.x86_64
libc.so.6(GLIBC_2.15)(64bit) is needed by sshpass-1.05-5.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by fdupes-1.51-6.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by arj-3.10.22-22.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by wireless-tools-1:29-13.el7.x86_64
libc.so.6(GLIBC_2.15)(64bit) is needed by wireless-tools-1:29-13.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by libwnck-2.31.0-1.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by libc-client-2007f-4.el7.1.x86_64
libc.so.6(GLIBC_2.15)(64bit) is needed by libc-client-2007f-4.el7.1.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by smp_utils-0.98-3.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by libmcrypt-2.5.8-13.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by unique-1.1.6-10.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by xclip-0.12-5.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by libva-1.2.1-3.el7.x86_64
libc.so.6(GLIBC_2.14)(64bit) is needed by libtidy-0.99.0-31.20091203.el7.x86_64

I already tried using yum --skip-broken without success.
Server's libc.so.6 is 2.12 and there's no update.
What can I do to solve this?

7

You installed the EPEL repository for CentOS 7, but you are running CentOS 6.

Remove the epel-release package and/or the EPEL repo files from /etc/yum.repos.d, and try again with the correct package.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.