8

Currently have a client that has poor eyesight and needs everything on his screen larger than standard. The issue is when running a Citrix application [Xenapp], the mouse is not scaling properly.

His local PC is set for 150% scaling with the mouse pointer set to extra large.
The Citrix application server is set for 125% scaling, mouse set to extra large.

The mouse shrinks significantly when I move from local to a hosted session.

When I increase the scaling to 150% on the server, then the mouse size is fine [stays same local and hosted], however, all the fonts in his applications are now too large to work with.

I've tried different combinations of local, hosted, but the mouse just wont scale properly. So my thought was to edit the mouse pack, just increase the size by 30%, but this doesn't seems as easy as it sounds.
Open to nudges in the right direction.

  • Can you elaborate on "but this doesn't seems as easy as it sounds"? – abstrask May 19 '16 at 11:08
  • 1
    You shouldn't need to replace the file, assuming that XenApp honors the system's mouse settings. In the "Mouse" settings, you can choose a different file to use for that cursor. To make a larger cursor, use any icon editor program (there are lots of them you can find online). – Moshe Katz May 19 '16 at 19:19
  • Check if the client app has the option not to import the cursor from the other side. If that's unavailable, change the mouse cursor on the remote machine. Also consider the High Contrast scheme. – Zdenek Jun 18 '18 at 17:50
  • Maybe use powershell to do the commands remote to that other machine? devblogs.microsoft.com/scripting/… – Jeshizaemon Oct 21 '19 at 8:01
0

If you have remote-assistance installed, and are able to shadow the user, you should get full desktop. From the full desktop go to Control panel, Mouse options, Pointers tab and change the "Scheme" option to Large or Extra large.

0

Font scaling is a system setting (per computer), so setting it on the Citrix server is noticeable when he logs on.

Mouse cursors are a profiles setting (per user), so you setting it on the Citrix server only sets it for yourself. When the user logs in they get their profile with the regular cursor.

You need to find a way of editing the mouse cursor for that user's profile on that server.

(For example temporarily grant him temporary access to a citrix full desktop and set the mouse cursor logged in as him. Log out to save the profile, then remove access to the temporary full desktop. If you have multiple Citrix servers you'll have to copy the profile to each one, or possibly look at redirection for the relevant profile folders.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.