2

I've setup an Azure virtual machine using Ubuntu 16.04LTS but I'm struggling to get remote desktop to work for it.

I've setup the endpoint as follows:

enter image description here

I've also setup and started xrdp as well as installed xfce4. For reference, here's my command history since creating the VM:

Update Packages and Install xfce4

sudo apt-get update

sudo apt-get install xfce4

Install xrdp

sudo apt-get install xrdp

sudo /etc/init.d/xrdp start

Create new user and add to sudo group

sudo adduser rdpuser

sudo adduser rdpuser sudo

Even after having done this I can still only SSH to my Virtual Machine. The RDP client is timing out with the following:

enter image description here

What am I missing?

3

You have your source port locked at 3389. This should be set to *, as it represents traffic origination port.

Your other settings look fine.

1
  • Thanks! I've updated this and also found that checkpoint was blocking my outgoing connection (registering it as the NoMachine client). Will accept as the answer since it looks like this wasn't working due to multiple things at play. – Michael A May 20 '16 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.