0

I'm trying to mount shares from our OSX server (10.11.5) onto my linux client (Ubuntu 15.10) after an upgrade to the server took place. Prior to the upgrade I was able to mount these directories without a problem using fstab entries like this:

//Server/Share /mnt/server/share cifs user=<user>,nounix,noauto,rw,uid=<user>,gid=<user> 0       0

However, after the upgrade I get the follow messages:

mount error(11): Resource temporarily unavailable
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I also cannot mount the shares from Nautilus. Other Mac clients ARE able to mount the shares. The linux client is able to mount SMB shares from other Ubuntu servers.

Running smbclient gives the following:

ntlmssp_handle_neg_flags: Got challenge flags[0x22810205] - possible downgrade 
detected! missing_flags[0x00080000] - NT code 0x80090302 
     NTLMSSP_NEGOTIATE_EXTENDED_SESSIONSECURITY
SPNEGO(ntlmssp) login failed: NT code 0x80090302
session setup failed: NT code 0x80090302

Which suggests issues with ntlmssp authentication. I have tried various sec= additions to fstab but to no avail.

The OSX sudo serveradmin settings smb output is as follows.

smb:ntlmv2 = no
smb:ntlmAuth = yes
smb:ServerDescription = "<REMOVED>"
smb:ntlmv2 auth = no
smb:wins server:_array_index:0 = _empty_dictionary
smb:spnego = no
smb:DOSCodePage = "437"
smb:NetBIOSName = "<REMOVED>"
smb:VirtualAdminShares = no
smb:logging = yes
smb:ntlm auth = yes
smb:AllowGuestAccess = no
smb:ntlmv2Auth = no
smb:LocalKerberosRealm = "<REMOVED>"

I have very little access to the OSX server and do not know the details of the upgrade (imperfect world I know). I am not officially in a position to make changes to the server directly but can request specific things be done.

Mounting in this direction (Ubuntu client, OSX server) appears uncommon and so I would appreciate any help, advice or even thoughts people might be willing to share.

1
  • Apparently this is related to the 'badlock' bug and the fixes that various clients have implemented.
    – Toenex
    Jun 7 '16 at 13:29
1

I recently revisited this and finally got it to work by adding vers=2.1 to the cifs options, thus;

//Server/Share /mnt/server/share cifs user=<user>,nounix,noauto,rw,uid=<user>,gid=<user>,vers=2.1 0 0

0

I also have issues with shares betwwen a linux client and OSx server (10.11.5).

Adding these lines to the global section of the smb.conf should clear the error message you are getting. However I do not believe you will be able to connect:

add:

client use spnego = no client ntlmv2 auth = no

to /etc/samba/smb.conf (this is the location on my linux box).

I got this from a helper(fzinken) on the OSMC forum (my client is osmc raberrypi machine) see also : https://discourse.osmc.tv/t/smb-shares-cannot-browse-after-update/3294/147

2
  • Yes adding these to the client side smb.conf file (under the [global] section) did indeed remove the error messages. This was helpful as I hadn't appreciated that smb.conf affected clients as well as servers. Thanks.
    – Toenex
    May 23 '16 at 7:53
  • The person from the other post mentions "sharing logs" where are these logs locates on the osx file server . Or how to you activate these logs on the osx file server
    – helper
    May 23 '16 at 19:52
0

It sounds like possibly you don't have the package cifs-utils installed on the clients. I see that you were already trying to connectd with cifs, which typically is a great way to troubleshoot osx-to-linux shares (cifs://<host>... rather than smb... for future readers), as a test or alternative. If you have it already though, read on...

You and the user "helper", below, are on the right track by saying "...[there are now] issues with ntlmssp authentication." This is likely the problem. A similar issue was reported and solved for Windows users... and also for Ubuntu users on Stack Overflow.

As you may know, OSX server, especiallay the newer versions like your 10.11-based system (That is actually Server 5.x) have a GUI where many functions are intended to be setup using this "Server.app", and can even conflict with changes or tweaks made in UNIX-land, so one should always start there first, and then, if needed dig deeper. I'm adding details here for the future use on this site:

  1. Get access to the Server.app front end; without seeing all the settings there, first, it is really dangerous to go into things like serveradmin.
  2. Verify that your output from serveradmin settings smb matches the settings File Sharing pane on Server.app, for example that SMB is enabled (there is a checkbox), and if no one is currently connected (see the next tab), use the large switch at the top-right to turn off and back-on the file-sharing service. Here is an image:

    File Sharing OSX example from Ars Technica

  3. Try and connect with smb directly in your fstab, because OSX Server is moving toward SMB as their preferred protocol (rather than afp), in the last several versions.

  4. If that didn't work, try again to connect with CIFS rather than SMB, after turning the shares back off and on.

  5. Try to manually connect with SMB from the client.

  6. Check out the sharing logs for further clues, and repeat steps as needed.

  7. I've seen no updated white-paper from Apple other than "Integration Basis, so if you're still not in, post an update please, and let's turn this into a wiki page here if needed, because we'll also have more information from you, e.g. if you've gotten access to the server now, It's hard to do much troubleshooting and digging in deeper to the man pages and stuff, for all of us, without comprehensive info.

2
  • 1
    I've checked what settings I can using Server.app and file sharing is on and working for my account - I can mount drives from an OSX client machine using Finder. As you say Apple are moving away from samba (which now carries a GPL license) to their own implementation of SMB, which doesn't help matters. However, I can confirm that the changes made using serveradmin are reflected in /Library/Preferences/SystemConfiguration/com.apple.smb.server.plist. My current work around is to mount the drives using nautilus using afp and access via /run/user/XXXX/gvfs as AFP sharing is still on
    – Toenex
    May 23 '16 at 8:25
  • I had mentioned that Apple was moving actually towards SMB (only vs. AFP), but the point--and your problem here--is exactly along the lines of how you mention they have their own, evolving SMB, so, ASAP someone here including myself can dive in deeper and perfect the answer, then hopefully you can use your choice of protocols, if AFP isn't a final solution for your Ubuntu mount. May 23 '16 at 12:29
0

I am running 10.11.5 as well and was attempting to connect from a machine running Ubuntu 14.04 through the GUI. That was not working, so I tried using mount.cifs from the command line, but was experiencing problems.

I added sec=ntlmssp to the options along with nounix as above and username=myusername (to get read/write access). It finally worked, but I still preferred to manage things through the GUI.

That's when I remembered (after hours of frustration) that Ubuntu's GUI can mount SFTP shares. Since I have SSH enabled on my OS X machine anyway, I just decided to go that route instead.

Not an optimal solution for some, but something to consider if you are not absolutely attached to SMB and need similar functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.