0

I am trying to install the latest version of btsyc on a CentOS 6.5 headless server. I cannot reach the WebUI.

I configured the webui on port 65000 via a config file and start btsync with the config file as an argument. This is confirmed by the command line reply when I start the service:

Webui is listening on 0.0.0.0:65000

The service itself is configured to run on port 8888. When I run lsof -Pnl +M -i4, I get the following output:

btsync 25687 500 9u IPv4 536416051 0t0 TCP *:8888 (LISTEN)

btsync 25687 500 10u IPv4 536416052 0t0 UDP *:8888

btsync 25687 500 13u IPv4 536416060 0t0 UDP *:3838

Nothing else seems to be listening on 65000. I tried netstat -tulpn as well and the results are the same. I added a rule to iptables and Iptables -L returns (among others):

ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:65000

Here are all the firewall rules. But anyhow, I tried to run btsync after having stopped the iptables service completely, and it was the same result.

The logfile sows the following:

[20160521 17:24:25.687] Configuration from file "/home/includes/btsync/btsync.conf" has been applied
[20160521 17:24:25.690] ZIP: Can't locate [version] in zip, error -100.
[20160521 17:24:25.692] PLC[0x000000000225a8c0] binding on 0.0.0.0:8888
[20160521 17:24:25.692] Socket[0x000000000225a8c0][9] bound listening socket 9 to IP 0.0.0.0:8888
[20160521 17:24:25.692] UDP: bound listening socket 10 to IP 0.0.0.0:8888
[20160521 17:24:25.694] test sha1: ****************
[20160521 17:24:25.694] test sha2: ****************
[20160521 17:24:25.694] test aes: ****************
[20160521 17:24:25.694] Loading config file version 2.3.7, current version 2.3.7
[20160521 17:24:25.694] My PeerID: 107408D3698D9BCA3EF7D****************
[20160521 17:24:25.695] LC: LoadLicenses: there is no pro license
[20160521 17:24:25.695] loaded history: 0 events
[20160521 17:24:25.697] setup socket 13 for local peer discovery for 127.0.0.1: success
[20160521 17:24:25.697] Debug log mask has been set to FFFFFFFF
[20160521 17:24:25.697] Features mask has been set to 0
[20160521 17:24:56.835] OpenSSL: Loaded X509 trusted CA from "/etc/pki/tls/certs/ca-bundle.crt"

I tried to run webui on a different port, the result is the same. I also tried to bind the webui on my server's IP address instead of 0.0.0.0, same result. Any ideas?

[Update] So I started this whole process again with a default config and on port 8888 and now it worked. As a recommendation for people in the future who have such an issue, try to use this command here:

curl -k http://xxx.xxx.x.xxx:8888/gui -v 

to see if the server is running from the server's command line. It should show a quite long bunch of HTML if the server is running properly. If that works, try to amend the config file from there on

  • Check your firewall. – Michael Hampton May 22 '16 at 9:27
  • @MichaelHampton thanks for he hint. As I wrote above, I set iptables (the linux firewall) to allow btsync through. If you see something wrong with my settings, please let me know. – uncovery May 22 '16 at 9:28
  • You didn't post your complete firewall rules, so it's impossible to say. – Michael Hampton May 22 '16 at 9:29
  • @MichaelHampton Thanks for the explanation. I added a link to the complete set above. – uncovery May 22 '16 at 9:35
3

From the official FAQ and the README from the downloaded package:

IMPORTANT NOTE: To improve security, the LAN listening interface is off unless you configure it. By default the WebUI is only accessible on the computer running Sync (localhost:8888). In order to have the WebUI accessible across the LAN, use a configuration file or start Sync this way:

$ ./btsync --webui.listen 0.0.0.0:8888

  • I am using a configuration file that instructs btsync to listen on the webui on port 6500. Anyhow Ialso tried the command line mode you just pasted here, and the effect is the same as above :-( – uncovery May 22 '16 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.