4

I'm trying to mount a samba network share on an Ubuntu 14.04 using cifs.

On the server, I've got the share running. I can already map it as a drive in Windows. The share has a username and password.

On the ubuntu machine, i've got /etc/samba/user where the credentials are saved. I also have the directory where I would mount the share /mounthere.

I have this on /etc/fstab

//192.168.1.1/sharename /mounthere cifs credentials=/etc/samba/user 0 0

When I do sudo mount -a I get this error:

mount error(112): Host is down

The host is not down. I've got it running on Windows. I've double checked the credentials and possible firewall issues.

I also have cifs-utils installed.

Can anyboby point me to the right direction.

Thank you!

  • Use tcpdump to trace connection negotiation to ensure that you are getting replies and they are not reset packets. – AlexD May 12 '17 at 11:05
  • @jarvis, have you tried debugging using smbclient? See here details: wiki.ubuntu.com/DebuggingSamba. It sounds more like a samba version mismatch. – Diamant May 12 '17 at 13:23
  • Also, check for authentication errors and SELINUX log entries in your messages and authentication logs (server side). And make sure the samba service has read on the credentials file (client side). Check the client side logs for relevant entries as well. Also, make sure the credentials includes the relevant domain, as in user@domain, where the domain is whatever authentication domain is used by the server for the account that is granted access. – Xalorous May 12 '17 at 14:17
  • 1
    What's the complete error message when running the command sudo mount /mounthere ? "host is down" is not a message from mount.cifs AFAIK. – wazoox May 12 '17 at 14:50
4
+75

There are at least three different versions of SMB around. The problem is, when you are just mounting SMB with no further option on the Linux kernel and SMBv1 is disabled on the server, then the server will send a TCP RST packet to the client and this results in the error you mentioned.

Add this option to your entry in the fstab command and check the results:

vers=3.0

This forces the kernel mount to use SMBv3 from the beginning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.