-1

I cannot get ejabberd to start after attempting to enable mod proxy_65 with the following settings:

{mod_proxy65,  [
                  {host, "secusrvr.com"},
                  {ip, {0,0,0,0}},
                  {hostname, "secusrvr.com"},
                 ]},

I get the following syntax error, but I can't see anything wrong:

=ERROR REPORT==== 2016-05-21 12:41:44 ===
E(<0.37.0>:ejabberd_config:187) : The following lines from your configuration file might be relevant to the error:
529:   %%{mod_muc_log,[]},
530:   {mod_offline,  [{access_max_user_messages, max_user_offline_messages}]},
531:   {mod_ping,     []},
532:   %%{mod_pres_counter,[{count, 5}, {interval, 60}]},
533:   {mod_privacy,  []},
534:   {mod_private,  []},
535:   {mod_proxy65,  [
536:              {host, "secusrvr.com"},
537:              {ip, {0,0,0,0}},
538:              {hostname, "secusrvr.com"},
539:             ]},
540:   {mod_pubsub,   [
541:              {access_createnode, pubsub_createnode},
542:              {ignore_pep_from_offline, true}, % reduces resource comsumption, but XEP incompliant

=ERROR REPORT==== 2016-05-21 12:41:44 ===
E(<0.37.0>:ejabberd_config:106) : Problem loading ejabberd config file /etc/jabber/ejabberd.cfg approximately in the line 539: syntax error before: ']'
0

You indeed have a syntax error. Your config file is wrong. Remove comma at end of line 538.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.