3

I'm attempting to set up icinga2 and icingaweb2 on a Ubuntu 16.04 system using mariadb as the database. I seem to have icinga set up OK (no errors in the icinga.log, apache error log or syslog) but when I try and navigate to the icinga2 web page I just get a blank page with the following code

<!--?php /*! Icinga Web 2 | (c) 2014 Icinga Development Team | GPLv2+ */ require_once '/usr/share/php/Icinga/Application/webrouter.php'; -->
<html>
    <head><head/>
    <body><body/>
</html>

I get the same code regardless of navigating to /icingaweb2 or /icingaweb2/setup. I have tried to configure the system manually using the instructions on the git documentation, but still the same behaviour.

Any ideas what might be going on here?

Peter.

1
  • I have now done a fresh install onto a new VM (again 16.04) following the instructions for icinga2 and icingaweb2 found at docs.icinga.org/icinga2/latest/doc/module/icinga2/chapter/… and am getting exactly the same thing with icingaweb2. It seems it is loading icingaweb2 but there is no content for some reason.
    – Peter Nunn
    Commented May 22, 2016 at 12:31

2 Answers 2

3

I had this issue. I follow this and it resolved the issue for me: icinga

resolution was: apt-get -y install php7.0 libapache2-mod-php7.0

cheers alexis

0

I tried the same and got some stack trace. Please see the ticket at https://bugs.launchpad.net/ubuntu/+source/icingaweb2/+bug/1574250

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .