0

Hello I am running ubuntu 14.04 and perl version 5.23.9 (compiled) When I try to build the IO::Socket::SSL module , the machine always freezes.

So I installed the module manually. Download from CPAN , perl Makefile.PL , make , make install works fine. If I run make test the machine freezes.

Why?

How can this be prevented?

2
  • What do you exactly mean with "the machine freezes" ? Hard freeze so that only a hard reset will help or just that make test does not show progress but you can continue to work on the machine? In case of hard freeze of the system I would consider it a kernel bug (or faulty hardware) since no user space application should be able to cause this. Maybe you should also add resource limits so that no application can starve your system by using too much resources. If the problem is reproducible and happens on the same place all the time please add more details (which test, version of openssl,...) May 23 '16 at 9:34
  • Have you tried on a different machine and gotten similar results?
    – chicks
    May 24 '16 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.