0

I create a new instance. Happens for both Amazon Linux or Ubuntu instances. I didn't try a windows instance.

Sometimes, I can log in once via ssh(putty). I do some cd .. and ls commands but that's it. I then get 'Software caused connection to Abort' from Putty. Future attempts at connection to the instance result in a "Connection timeout error".

I tried connecting with my Windows 10 Desktop, iMac and my Win10 Laptop (same router). My security group allows ssh (I tried allowing everything). Reboot the instance doesn't help.

I don't know how access Aws instances without ssh. Thanks.

EDIT:

I found some threads from 2011 with a similar issue

https://forums.aws.amazon.com/message.jspa?messageID=251001#251001

https://forums.aws.amazon.com/message.jspa?messageID=246274

EDIT 2: Issue solved

Long story short: My account a long time ago was suspended (and unknowingly put into "isolation"). Then I got my account reactivated. Account Support said it was a technical issue. I paid for Tech Support for 2 months, Tech Support realized this was an account issue. I received a refund and $100 in AWS credits.

1

Solution: Ask customer support if your account is put into isolation and have them remove it. This behavior will most likely only happen if your account was suspended and it wasn't removed when it was re-activated. Account Isolation can at the region level.

0

The AWS instance install is the most obvious common point in this scenario, followed by your internet connection / router.

First try ssh'ing in from a spot instance in the same AZ and check it's reliable, to make sure it's not your VM. You could try from an AZ in a different region to double check. This should cost you around 10c total.

Next try from a completely different internet connection, ideally from a different computer.

I've used putty to control many AWS instances from many internet connections and I've never had that issue.

  • On a network different from my home, I tried connecting over SSH. Then I created a 2nd windows instance and rdp'd into it. I was able to connect for a couple of minutes while it was logging in and then connection dropped. I was no longer able to connect to the windows instance. – Paul Totzke May 24 '16 at 18:39
  • Interesting. You said what happened with the Windows instance, but what happened with the SSH session? Assuming you used a different PC this means the problem is either with the AWS instance, AWS account, or you. I'd be willing to try from my computer for you, probably into a spot instance not your actual server, but that would mean quite a bit of work for you to create a new IAM user, create keys, check it works, and provide access, etc. – Tim May 24 '16 at 21:08
  • It took a while, but its solved now! – Paul Totzke Jul 11 '16 at 15:00
  • You should tell people what the problem was, and also accept the best answer. – Tim Jul 11 '16 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.