I am building a Windows 10 x64 Reference image in MDT 2013 U2. It’s a thick image, as we need several large software installations, so we don’t need to spend hours deploying the image, if we installed the software in the deployment process instead of in the build process.

Therefor building the image takes more than 1 hour, and I have found, that if Windows 10 is online for more than 1 hour, it starts downloading and staging updates for the built-in apps. It is these updates that result in sysprep failing. It can be found in the setuperr.log:

2016-05-24 20:40:15, Error                 SYSPRP Package Microsoft.WindowsAlarms_10.1510.12020.0_x64__8wekyb3d8bbwe was installed for a user, but not provisioned for all users. This package will not function properly in the sysprep image.

2016-05-24 20:40:15, Error                 SYSPRP Failed to remove apps for the current user: 0x80073cf2.

2016-05-24 20:40:15, Error                 SYSPRP Exit code of RemoveAllApps thread was 0x3cf2.

2016-05-24 20:40:15, Error      [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'SysprepGeneralizeValidate' from C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
2016-05-24 20:40:15, Error                 SYSPRP SysprepSession::Validate: Error in validating actions from C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
2016-05-24 20:40:15, Error                 SYSPRP RunPlatformActions:Failed while validating SysprepSession actions; dwRet = 0x3cf2
2016-05-24 20:40:15, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x3cf2
2016-05-24 20:40:15, Error      [0x0f00d8] SYSPRP WinMain:Hit failure while pre-validate sysprep generalize internal providers; hr = 0x80073cf2

Microsoft has acknowledged this problem since Windows 8, but hasn’t come up with a permanent solution yet (it's almost 4 years since Windows 8). So it persists in Windows 10 (version 1511 – the most recent). It’s described here: https://support.microsoft.com/en-us/kb/2769827

The suggested solution is not very useful:

To prevent Windows Store from updating apps, unplug the Internet connection or disable Automatic Updates in Audit mode before you create the image

I need my reference image to be fully updated using WSUS. I also need to be able to connect to the MDT server, to install the software. So disconnecting the reference image is not an option.

Byt the way, I have tested this problem by uninstalling all apps in the build process, so there are no apps to stage updates for, and then sysprep runs fine. But I need some of these apps in the image (i.e. Calculator, Alarms etc.). So this is not an option either.

Disabling the Windows Update service will also disable the normal Update process, which runs during the build, so that is not a solution either.

How can I disable the automatic update of the built-in apps?

up vote 1 down vote accepted

I came up with a solution: I automated it by enabling and exporting a local GPO setting with LGPO.exe:

Local Computer Policy > Administrative Templates > Windows Components > Store:

"Turn off Automatic Download and install of updates"

Then I apply it in the State Restore phase. I also added a Task Sequence Variable for GPOPackPath, so I can handle more GPOPacks if needed later on.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.