3

I tried to migrate from Apache to Lighttpd on kubuntu 16.04. I used apt-get remove --purge apache2 then apt-get install lighttpd

After running systemctl start lighttpd I got the error message

 Job for lighttpd.service failed because the control process exited with error code. See "systemctl status ligttpd.service" and "journalctl -xe" for details.

The contents of journalctl -xe is: The result is failed.

Mai 25 15:25:36 Heizschrank systemd[1]: lighttpd.service: Unit entered failed state.
Mai 25 15:25:36 Heizschrank systemd[1]: lighttpd.service: Failed with result 'exit-code'.
Mai 25 15:25:36 Heizschrank systemd[1]: Reloading.
Mai 25 15:25:36 Heizschrank systemd[1]: apt-daily.timer: Adding 7h 10min 31.972833s random time.
Mai 25 15:25:36 Heizschrank systemd[1]: Started CUPS Scheduler.

-- Subject: Unit cups.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit cups.service has finished starting up.
-- 
-- The start-up result is done.

Mai 25 15:25:36 Heizschrank systemd[1]: Started ACPI event daemon.
-- Subject: Unit acpid.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit acpid.service has finished starting up.
-- 
-- The start-up result is done.

Mai 25 15:25:41 Heizschrank sudo[22105]: pam_unix(sudo:session): session closed for user root

The output of systemctl status is:

● lighttpd.service - Lighttpd Daemon
Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mi 2016-05-25 15:25:36 CEST; 26min ago

Mai 25 15:25:36 Heizschrank systemd[1]: Starting Lighttpd Daemon...
Mai 25 15:25:36 Heizschrank lighttpd[23079]: /usr/sbin/lighttpd: symbol lookup error: /usr/sbin/lighttpd: undefined symbol: FAMNoExists
Mai 25 15:25:36 Heizschrank systemd[1]: lighttpd.service: Control process exited, code=exited status=127
Mai 25 15:25:36 Heizschrank systemd[1]: Failed to start Lighttpd Daemon.
Mai 25 15:25:36 Heizschrank systemd[1]: lighttpd.service: Unit entered failed state.
Mai 25 15:25:36 Heizschrank systemd[1]: lighttpd.service: Failed with result 'exit-code'.</p>

I tried reinstalling lighttpd multiple times, but I get the same error. How could I now run lighttpd without causing errors?

  • ow my eyes... please replace your html tags with normal formatting. Just add a blank line and then indent the journalctl output instead of this eyesore. – Peter May 25 '16 at 13:46
  • The journalctl output seems to be completely irrelevant... try systemctl status instead. Or do the normal non-systemd way... run it in debug foreground mode. For example /usr/bin/lighttpd -D -f /etc/lighttpd/lighttpd.conf and then you'll see the output of the program itself. – Peter May 25 '16 at 13:49
  • Find the path of lighttpd rather than guessing... try "which lighttpd" to see if it's in PATH, or use dpkg -L lighttpd | grep bin or grep through the .service file or init script. – Peter May 25 '16 at 14:03
  • btw. also in the added output, you can see the path is /usr/sbin/lighttpd which ought to be in root's PATH – Peter May 25 '16 at 14:09
8

Okay, I see in the new output there that this is a known bug. See https://bugs.launchpad.net/ubuntu/+source/lighttpd/+bug/1453463

The text I looked for was:

undefined symbol: FAMNoExists

And the suggested workaround there is:

sudo apt-get install gamin
|improve this answer|||||
  • Had the same issue on Ubuntu 15.10 as well, and this worked. Thanks! – Priidu Neemre Dec 4 '16 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.