I have a new vm setup and have it setup like my CentOS 5.5 vm on OSX. It is a strange setup since we used Comcast Gateway as the router, and I really don't want to change that since we're using Mac, and Apple routers only allow,, and So, I have a Mac box setup with a static from my static IP block. I then have a vm instance running CentOS 5.5 and my ifcfg file only has another static address from the same block; and we have a default gw of

On my 6.7 vm on the same box, I've set it up with another static from the same block and have tried everything exactly like the 5.5 setup. We can ping and such but can't ping from outside in.

IP Summary:

My IP block is

  • Router
  • Netmask
  • Gateway IP
  • Mac Server
  • CentOS 5.5 vm
  • CentOS 6.7 vm

I understand that in reality the addresses should be on the same netwok rather than as the "router," but this is how it is setup, and is working for and, which like I said, are on the same server and vmware. Not sure why 6.7 is acting differently.

I have tried with and without NM controlled, adding static routes in CentOS 6.7, and adding and deleting default gw...

A traceroute from outside shows this route:
  • I understand the interest of hiding your actual IPs but your description is confusing. Does the traceroute show exactly the same thing as one that is functioning except for the final IP? May 25, 2016 at 19:44
  • We prefer that you do not obfuscate IP addresses. If for some reason you still feel that you must, use the ranges given in RFC 5737. May 25, 2016 at 20:08

2 Answers 2

1 is a private address on your LAN. looks like a public-facing address. It looks like you're trying to route your traffic internally and externally at the same time. If your router is a (as noted by the netmask everything else needs to be on the same subnet to connect, unless you have a vlan set up (very doubtful based on what you've described).

I would set up everything on the LAN (behind the DMZ or firewall or at least router) and either use dynamic NAT or PAT


It sounds like you know all about traditional subnetting conventions, but I'm just going to walk through your setup one thing at a time for people reading this later.

I'm sure you have confirmed that is actually an available address from your agreement with your ISP, Comcast? Try assigning ...196 to your new vm if you haven't done that already.

I say this first, because You mentioned "default gw of," which is your router, and so then we're assuming that what you mean later by "gateway IP" is one of the reserved addresses (out of only 8 total including broadcast, router, network) according to your /29 IP block, from the ISP., which doesn't leave any room for numbering errors.

Also make sure the ethernet on your vm is up, according to the release notes for 6.7 "Many people have complained that Ethernet interfaces are not started with the new default NetworkManager tool."

It said the same thing in the notes for 6.6, and as well, it said several new features were added for vm setups, so perhaps some new bug from CentOS is just simply breaking your setup?

The firewall is really restrictive by default, as well, so do something like sudo iptables -L to confirm your public services are not blocked.

If you have the router on the LAN setup as with the netmask, and this is what you've actually got in the network Settings in all the network clients, for example on the OSX machine (your external, you would need to have setup in the Network pane of System Preferences an address like, for example, but then be broadcasting for the public services (for example in OSX Server in the very first settings item (Server -> Overview -> Internet) where it says "Reachable at:" it should say

I'm assuming that in your Comcast router you've setup as the address of the router, and that this is actually performing NAT as specified by your ISP such that the server Mac is reachable at as described above, and in your question; however, you did not mention the actual LAN address of the Mac, because it must have a 10.1.10.x address or it would not even be reachable to serve up your old CentOS vm.

If that is all setup exactly as you described, then as long as you have a correct address on your new vm, it should work. Please comment or update your post if any of that is incorrect, so we can proceed and get a correct answer for you.

  • Yes all of this was correct as you stated. It has to be a bug in 6.6 and 6.7 because I just did a clean install of 6.8 and worked perfectly just as before. However the only thing that is strange is that my CentOS 5 accepts as a default gw which is the router address but I used for 6.8 which is my gw IP which seemed to work. So much trouble I was afraid to test haha. thanks!
    – Chad Sims
    Jun 10, 2016 at 19:07
  • it would be cool if you marked mine or the other person's answer as "chosen", or wrote up your own answer that explains there was a bug, just so the question will get closed. thanks for the update. Jul 15, 2016 at 18:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .