0

I have a new vm setup and have it setup like my CentOS 5.5 vm on OSX. It is a strange setup since we used Comcast Gateway as the router, and I really don't want to change that since we're using Mac, and Apple routers only allow 192.168.1.1, 172.16.1.1, and 10.0.1.1. So, I have a Mac box setup with a static from my static IP block. I then have a vm instance running CentOS 5.5 and my ifcfg file only has another static address from the same block; and we have a default gw of 10.1.10.1.

On my 6.7 vm on the same box, I've set it up with another static from the same block and have tried everything exactly like the 5.5 setup. We can ping 8.8.8.8 and such but can't ping from outside in.

IP Summary:

My IP block is 70.88.182.198/29

  • Router 10.1.10.1
  • Netmask 255.255.255.0
  • Gateway IP 70.88.182.198
  • Mac Server 70.88.182.197
  • CentOS 5.5 vm 70.88.182.195
  • CentOS 6.7 vm 70.88.182.194

I understand that in reality the 70.88.182.0 addresses should be on the same netwok rather than 10.1.10.1 as the "router," but this is how it is setup, and is working for 70.88.182.197 and 70.88.182.195, which like I said, are on the same server and vmware. Not sure why 6.7 is acting differently.

I have tried with and without NM controlled, adding static routes in CentOS 6.7, and adding and deleting default gw...

A traceroute 70.88.182.195 from outside shows this route:

192.168.0.1
96.120.4.57
174.49.69.60
70.88.182.195
2
  • I understand the interest of hiding your actual IPs but your description is confusing. Does the traceroute show exactly the same thing as one that is functioning except for the final IP? May 25 '16 at 19:44
  • We prefer that you do not obfuscate IP addresses. If for some reason you still feel that you must, use the ranges given in RFC 5737. May 25 '16 at 20:08
1

10.0.1.1/24 is a private address on your LAN. 70.88.182.1/24 looks like a public-facing address. It looks like you're trying to route your traffic internally and externally at the same time. If your router is a 10.0.1.1/24 (as noted by the netmask 255.255.255.0) everything else needs to be on the same subnet to connect, unless you have a vlan set up (very doubtful based on what you've described).

I would set up everything on the LAN (behind the DMZ or firewall or at least router) and either use dynamic NAT or PAT

0

It sounds like you know all about traditional subnetting conventions, but I'm just going to walk through your setup one thing at a time for people reading this later.

I'm sure you have confirmed that 70.88.182.194 is actually an available address from your agreement with your ISP, Comcast? Try assigning ...196 to your new vm if you haven't done that already.

I say this first, because You mentioned "default gw of 10.1.10.1," which is your router, and so then we're assuming that what you mean later by "gateway IP" is one of the reserved addresses (out of only 8 total including broadcast, router, network) according to your /29 IP block, from the ISP., which doesn't leave any room for numbering errors.

Also make sure the ethernet on your vm is up, according to the release notes for 6.7 "Many people have complained that Ethernet interfaces are not started with the new default NetworkManager tool."

It said the same thing in the notes for 6.6, and as well, it said several new features were added for vm setups, so perhaps some new bug from CentOS is just simply breaking your setup?

The firewall is really restrictive by default, as well, so do something like sudo iptables -L to confirm your public services are not blocked.

If you have the router on the LAN setup as 10.1.10.1 with the netmask 255.255.255.0, and this is what you've actually got in the network Settings in all the network clients, for example on the OSX machine (your external 70.88.182.197), you would need to have setup in the Network pane of System Preferences an address like 10.1.10.3, for example, but then be broadcasting 70.88.182.197 for the public services (for example in OSX Server in the very first settings item (Server -> Overview -> Internet) where it says "Reachable at:" it should say 70.88.182.197.

I'm assuming that in your Comcast router you've setup 10.1.10.1 as the address of the router, and that this is actually performing NAT as specified by your ISP such that the server Mac is reachable at 70.88.192.197 as described above, and in your question; however, you did not mention the actual LAN address of the Mac, because it must have a 10.1.10.x address or it would not even be reachable to serve up your old CentOS vm.

If that is all setup exactly as you described, then as long as you have a correct address on your new vm, it should work. Please comment or update your post if any of that is incorrect, so we can proceed and get a correct answer for you.

2
  • Yes all of this was correct as you stated. It has to be a bug in 6.6 and 6.7 because I just did a clean install of 6.8 and worked perfectly just as before. However the only thing that is strange is that my CentOS 5 accepts 10.1.10.1 as a default gw which is the router address but I used 70.88.182.198 for 6.8 which is my gw IP which seemed to work. So much trouble I was afraid to test 10.1.10.1 haha. thanks!
    – Chad Sims
    Jun 10 '16 at 19:07
  • it would be cool if you marked mine or the other person's answer as "chosen", or wrote up your own answer that explains there was a bug, just so the question will get closed. thanks for the update. Jul 15 '16 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.