1

I tried to set up redis sentinel to make it has high availability and support fail over. I begin by setup the redis replication (1 master and 2 slaves in 3 ec2-instances)

And after that, i install redis-sentinel service for each instance.

However, when i tried to access redis-sentinal remotely (from my local machine) It shows following message

DENIED Redis is running in protected mode because protected mode is enabled, no bind address was specified, no authentication password is requested to clients....

So, i tried to set requirepass in sentinel.conf. But after i run redis-cli -h REDIS-IP -a PASSWORD -p SENTINEL_PORT INFO

It shows following

NOAUTH Authentication required.

Is there anyway i could connect to redis-sentinel remotely?

Please advise.

  • Any luck figuring this out? I'm running into the same issue with 3.2. The only option I have found so far is to disable protected mode by setting bind 0.0.0.0 in the configuration file, but that opens up sentinel to anyone...not good. – nerdherd Jun 15 '16 at 19:22
  • Please check this issue github.com/antirez/redis/issues/3279 @nerdherd – chaintng Jun 27 '16 at 2:14
0

It will be fixed in the new release https://github.com/antirez/redis/issues/3279

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.