1

While setting up an elastic beanstalk environment in AWS, it is possible to start it with an RDS instance, so RDS configurations will be present in the elastic beanstalk's config panel.

While setting up the RDS, it is possible to choose a snapshot I would like to be loaded.

It seems that I can only choose snapshots which have the same MySQL version as the new RDS instance.

Is it possible to workaround this limit? I would like to start an RDS instance with the most recent version of MySQL from an old-versioned MySQL instance. All I need is its data. That's it.

0

Do the upgrade ahead of time.

  1. Launch a fresh RDS from the snapshot. This instance will be temporary.
  2. Upgrade the new instance to your desired version.
  3. Create a new snapshot.
  4. Use this new snapshot for your new RDS instance.
3
  • Not sure about that. You can only migrate an RDS instance to a different DB Engine, not a higher major version of its current DB Engine. – Garreth McDaid May 30 '16 at 13:02
  • RDS Instances versions can be upgraded. For example, from 5.6 to 5.7 or from 5.6.1 to 5.6.2. This is done from the "Modify" menu. – Matt Houser May 30 '16 at 13:46
  • Your are correct. Apologies. – Garreth McDaid May 30 '16 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.