13

I have been using the "EnableLinkedConnections" registry setting below for years with no trouble. But lately with Windows 8.1 and Windows 10, sometimes it doesn't work. I need to run some programs with administrative privileges but they cant see drives mapped as a standard user when this is the case. Does anyone know why this no longer works? Or if there is a work around? Disabling UAC is not an option. Thanks

Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System Create a new parameter (DWORD type) with the name EnableLinkedConnections and the value 1

0

3 Answers 3

5

TLDR: Microsoft has acknowledged a case where EnableLinkedConnections will fail to work. This will occur if UAC requires a password before running an elevated program (ie running as admin).


https://support.microsoft.com/en-us/help/3035277/mapped-drives-are-not-available-from-an-elevated-prompt-when-uac-is-co

Symptoms

This issue occurs when the following conditions are true:

  • You use Group Policy Preference (GPP) or logon scripts to map network drives during logon.

  • User Account Control (UAC) is enabled.

  • The following UAC Group Policy setting is configured to Prompt for credentials:

    • User Account Control: Behaviour of the elevation prompt for administrators in Admin Approval Mode
  • The EnableLinkedConnections registry entry is configured. See the detail to configure the registry entry.

Under these conditions, you experience the following situation:

  • When you log on, mapped drives are available as expected. When you run an elevated command prompt as administrator, the mapped drives are unavailable in the elevated command prompt.

Note This issue also affects other applications that run in an elevated context (run as administrator) and use drive letters to access mapped drives.

Cause

When UAC is enabled, the system creates two logon sessions at user logon. Both logon sessions are linked to one another. One session represents the user during an elevated session, and the other session where you run under least user rights.

When drive mappings are created, the system creates symbolic link objects ("DosDevices") that associate the drive letters to the UNC paths. These objects are specific for a logon session and are not shared between logon sessions.

Note The EnableLinkedConnections registry entry forces the symbolic links to be written to both linked logon sessions that are created, when UAC is enabled.

When the UAC policy is configured to Prompt for credentials, a new logon session is created in addition to the existing two linked logon sessions. Previously created symbolic links that represent the drive mappings will be unavailable in the new logon session.

Workaround

To work around this issue, follow the steps in one of the following methods:

Method 1

  1. In Local Group Policy Editor, locate the following Group Policy path: Local Computer Policy\Windows Settings\Security Settings\Local Policies\Security Options

  2. Configure the following policy to Prompt for consent: User Account Control: Behaviour of the elevation prompt for administrators in Admin Approval Mode

Method 2

Map the required drives again in the elevated session, for example, by using a .bat script file.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.


A link to a similar bulletin was provided in a comment above, but didn't seem to be for English language users; the link in this answer should be for English locale.

4
  • I tried Method 1 and it still doesn't work.
    – boggy
    Commented Nov 11, 2020 at 23:06
  • I tried Method 2, and it worked. According to Autodesk, the Windows feature "SMB Direct" must be enabled for EnableLinkedConnections to work. See here. Commented Aug 31, 2022 at 11:27
  • @NickWestgate I'm not sure that SMB Direct information is correct. Microsoft doesn't mention it. And if you google carefully for both "smb direct" and "enablelinked connections it turns out that AutoDesk and a # of other miscellaneous websites have just copied the same text from each other which makes this claim. Example. Commented Sep 6, 2022 at 13:16
  • @StayOnTarget: Yeah, I haven't validated the SMB Direct anecdote as that feature was already enabled, but mentioned it just in case. I just wanted to note somewhere that Method 2 can work, as it did for me, and found your answer, so thanks! Commented Sep 7, 2022 at 5:35
1

I got some solutions which are:

  1. Turn off your UAC (User Account COntrol) and restart your PC and if this doesn't help go for the second solution it will surely help you.

  2. You have to create EnableLinkedConnections entry in the registry, set the value (type DWORD) to 1 and then restart the workstation. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLinkedConnections=dword:00000001

Note: To configure the EnableLinkedConnections registry value you need to follow these steps:

  1. Click Start, type regedit in the Start programs and files box, and then press ENTER.

  2. Locate and then right-click the registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.

  3. Point to New, and then click DWORD Value.

  4. Type EnableLinkedConnections, and then press ENTER.

  5. Right-click EnableLinkedConnections, and then click Modify.

  6. In the Value data box, type 1, and then click OK.

  7. Exit Registry Editor, and then restart the computer.

5
  • 1
    I AM using that registry key as stated. It did work once, but isn't anymore. That's my problem. Disabling UAC isn't an option.
    – JimDel
    Commented Jun 15, 2016 at 15:45
  • Is this error appears: "The system cannot find the path specified.." Commented Jun 16, 2016 at 4:09
  • Well that can be one of many errors due to this no longer working.
    – JimDel
    Commented Jun 16, 2016 at 14:29
  • Restarting the computer worked for me in Windows 10, and I could keep UAC enabled. Commented Oct 21, 2016 at 13:22
  • It didn't work for me! Windows 10 is the most brain dead operating system there is.
    – boggy
    Commented Nov 11, 2020 at 23:04
0

The answers above didn't work for me, but this did:

  1. Create a .cmd script, like fix-mounts.cmd
net use f: \\vboxsvr\myhome
"C:\Program Files\foo\the-thing-i-want-to-run-with-network-shares.exe"
  1. Create a shortcut to fix-mounts.cmd
  2. Right-click->Properties on the shortcut
  3. Click advanced
  4. Click "Run as administrator"
  5. click OK, OK.

Now double-click the shortcut and it will run as administrator, mount your shares, and launch the program.

Additionally, if you turn off UAC then it won't prompt to run as admin.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .