0

I have an Exchange 2010 server and have introduced an Exchange 2016 server in coexistence. Everything works but the ActiveSync.

When logging into the Exchange 2016 Active Sync with a 2016 mailbox it works fine. But when logging on to 2016 with a 2010 mailbox the request fails.

If I test this on the test connectivity I get:

Attempting to send the OPTIONS command to the server.
Testing of the OPTIONS command failed. For more information, see Additional Details.
 Tell me more about this issue and how to resolve it

Additional Details

An HTTP 401 Unauthorized response was received from the server. This may be the result of invalid credentials or a configuration problem on the Exchange Server. HTTP Response Headers: request-id: 106fa338-a1d3-4401-81b9-eacf1e834221 X-CalculatedBETarget: Exchange2010.domain.local X-FEServer: Exchange2016 Content-Length: 0 Cache-Control: private Date: Fri, 03 Jun 2016 12:24:54 GMT Set-Cookie: ClientId=YCFBIDWLKUA1QOQQQFDS; expires=Sat, 03-Jun-2017 12:24:54 GMT; path=/; secure; HttpOnly Server: Microsoft-IIS/8.5 WWW-Authenticate: Basic realm="mail.domain.co.uk" X-AspNet-Version: 4.0.30319 X-Powered-By: ASP.NET Elapsed Time: 1100 ms.

I have done lots of little tweaks in configuration but nothing seems to work. It must be something to do with the proxy to Exchange 2010 server. Any suggestions would greatly be appreciated.

  • I have done lots of little tweaks in configuration but nothing seems to work - Our knowing what those are would be helpful. – joeqwerty Jun 3 '16 at 14:26
  • Applied: support.microsoft.com/en-us/kb/3140410 As an article made this a possible cause from the 2010 side Changed the default app pool on both sides to run as the network service Tried it with Windows Auth both enabled and disabled on both sides Tried with SSL offload enabled and disabled both sides – Christopher Dickie Jun 3 '16 at 14:33
0

After many hours on the phone with Microsoft and many tweaks the only solution in the end was to completely remove the 2010 activesync virtual directory and recreate it

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.