1

Can anyone lend me some assistance in repairing my server 2012 R2 image?

I have a 2012 R2 VM, and have attached the install DVD we used from our datastore. I am then running the command:

dism /online /cleanup-image /restorehealth /source:WIM:D:\sources\install.wim:1 /limitaccess

I can see the WIM exists in that location:

Source WIM location

The tool runs and stays at 20% for a while, then fails with an error that states:

Error: 0x800f081f, The source files could not be found

The DISM log states several error lines:

DISM package manager: The source files could not be found; their location must be specified using the /source option to restore the feature

The CBS log has loads of lines saying:

Failed to getfile from WIM sandbox process [HRESULT = 0x80070003 - ERROR_PATH_NOT_FOUND]
Failed to look for the file WinSxS\wow64_some_package_name
Repr: not able to find replacement file for compenent

Followed by plenty of lines that say:

Repair failed: missing replacement payload.
(p) CSI Payload Corrupt

Can anyone tell me why it says the files cannot be found, when I am pointing at the same install.wim that was used to install Windows in the first place?

I even tried to extract the WIM to a location on the C:\ drive and use that, but failed with the same error.tel

Running /startcomponentcleanup results in error 14098, and DISM log says 0x80073712, which means CBS manifest is corrupt? Solution to which, laughably, is to run /restorehealth :P

1

I know this is late but have yet to find an answer to this. Your ISO Server 2012 R2 will have more than just Std server 2012 r2 it might have a core install too and maybe datacentre install. You have to change indexes for the win command to work with your version.

DISM.exe /Online /Cleanup-Image /RestoreHealth /Source:wim:c:\install.wim:1 /LimitAccess

on my 2012 R2 stand/datacenter media it has 4 indexes, to repair I need to make sure I use the right one using the below command I can check the index name

dism /get-wiminfo /wimfile:c:\install.wim /index:1 
dism /get-wiminfo /wimfile:c:\install.wim /index:2
dism /get-wiminfo /wimfile:c:\install.wim /index:3
etc...

Index : 1
Name : Windows Server 2012 R2 SERVERSTANDARDCORE
Index : 2
Name : Windows Server 2012 R2 SERVERSTANDARD
Index : 3
Name : Windows Server 2012 R2 SERVERDATACENTERCORE
Index : 4
Name : Windows Server 2012 R2 SERVERDATACENTER

so for my install I use

DISM.exe /Online /Cleanup-Image /RestoreHealth /Source:wim:c:\install.wim:4 /LimitAccess

I use Index 4 since I installed a GUI version of Datacenter

0

In the end, I tried a different repair source (Another 2012 R2 ISO I had, same version number I think but from a different download source).

I still got some component store corruption messages in the CBS log, but it seemed to fix enough to allow Windows Update to start working again.

Think I will do a restart and try an online repair using WU as the repairsource.

0

I ran the below command to verify my install type:

dism /get-wiminfo /wimfile:c:\install.wim /index:2

and then repaired with:

dism /Online /Cleanup-Image /RestoreHealth /Source:wim:c:\install.wim:1 /LimitAccess

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.