Our system experienced a hard reboot, and when it came up, we started getting panics. The boot mount was on an LVM volume. We recovered the GPT partition but all of the LVM commands that I have run have seemed to indicated that no LVM volumes are present. It also looks like LVM partitions should be prefixed with the text-config file (for rescue reasons) but we just have binary data (which makes me nervous).

Is there a more forensic/aggressive recovery method for LVM?


Our system experienced a hard reboot, ... We recovered the GPT partition...

There should be no need to recover GPT after hard reboot. Either the recovery of GPT went wrong or there is another problem there.

You should be looking for PV header ("LABELONE\001") on the disk - this should be at the offset 512 of the partition.

Also you have tagged the question raid - what RAID is/was there? Was the RAID assembled correctly?

  • It's on top of a hardware RAID, but it's not relevant. I've removed that tag. There was a malformed GPT partition table. FDISK read it (though misinterpreted it), but confused us. When we ran gdisk, it identified that there some issue that allowed one (two?) partition table(s) to be interpreted as either an MSDOS or GPT partition table. One of our guys had chosen to repair but then the host interfered and the recovery ISO got ejected and he thought he had screwed things up. We tried the gdisk repair when prompted, again, after backing up and everything worked. – Dustin Oprea Jun 29 '16 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.