0

I have Webmin on Debian. I want to add 3 domain names to the virtualhost but for some reason all 3 domain names serve the same page when browsing to the domain names.The page that shows on all 3 websites is the index.php test file I placed on itnerd.nl. How to fix this?

This is what i get when using apachectl -S

    VirtualHost configuration:
[2001:41d0:8:e2a1::1]:80 is a NameVirtualHost
     default server itnerd.nl (/etc/apache2/sites-enabled/itnerd.nl.conf:1)
     port 80 namevhost itnerd.nl (/etc/apache2/sites-enabled/itnerd.nl.conf:1)
178.32.223.161:80      is a NameVirtualHost
     default server itnerd.nl (/etc/apache2/sites-enabled/itnerd.nl.conf:1)
     port 80 namevhost itnerd.nl (/etc/apache2/sites-enabled/itnerd.nl.conf:1)
wildcard NameVirtualHosts and _default_ servers:
*:80              www.thememonster.nl (/etc/apache2/sites-enabled/www.thememonster.nl.conf:1)
Syntax OK
  • show us the contents of the configuration files shown by apachectl -S – rda Jun 6 '16 at 12:48
0

Here are the following 2 config files:

<VirtualHost 178.32.223.161:80 [2001:41d0:8:e2a1::1]:80>

SuexecUserGroup "#1003" "#1002" ServerName itnerd.nl ServerAlias www.itnerd.nl ServerAlias webmail.itnerd.nl ServerAlias admin.itnerd.nl DocumentRoot /home/itnerd/public_html ErrorLog /var/log/virtualmin/itnerd.nl_error_log CustomLog /var/log/virtualmin/itnerd.nl_access_log combined ScriptAlias /cgi-bin/ /home/itnerd/cgi-bin/ ScriptAlias /awstats/ /home/itnerd/cgi-bin/ DirectoryIndex index.html index.htm index.php index.php4 index.php5 Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch +ExecCGI allow from all AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch AddType application/x-httpd-php .php AddHandler fcgid-script .php AddHandler fcgid-script .php5 FCGIWrapper /home/itnerd/fcgi-bin/php5.fcgi .php FCGIWrapper /home/itnerd/fcgi-bin/php5.fcgi .php5 allow from all AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch RewriteEngine on RewriteCond %{HTTP_HOST} =webmail.itnerd.nl RewriteRule ^(.) https://itnerd.nl:20000/ [R] RewriteCond %{HTTP_HOST} =admin.itnerd.nl RewriteRule ^(.) https://itnerd.nl:10000/ [R] RemoveHandler .php RemoveHandler .php5 php_admin_value engine Off FcgidMaxRequestLen 1073741824 AuthName "itnerd.nl statistics" AuthType Basic AuthUserFile /home/itnerd/.awstats-htpasswd require valid-user Alias /dav /home/itnerd/public_html DAV on AuthType Basic AuthName "itnerd.nl" AuthUserFile /home/itnerd/etc/dav.digest.passwd Require valid-user ForceType text/plain Satisfy All RemoveHandler .php RemoveHandler .php5 RewriteEngine off

And the other one:

<VirtualHost *:80>

DocumentRoot "/home/thememonster.nl/public_html" ServerName www.thememonster.nl allow from all Options None

I also had a virtual host for itmonsters.tk but i removed it. Still when i go to itmonsters.tk and thememonster.nl i get the index page which only needs to be shown for itnerd.nl. Any fix for this?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.