0

I need help figuring out why the time source on some PCs keeps changing. Right now they're on Local CMOS clock. If I do w32tm /config /syncfromflags:domhier /update net stop w32time net start w32time then do a w32tm /query /status, they state they are getting their time from a domain controller. But then if I reboot the PC, it reverts back to Local CMOS clock.

I don't see anything in Group Policy that sets the time source. In fact, the PCs having this problem are in the same OU with some that aren't so I don't think it's Group Policy. They are on a different subnet, though. Can a router change the time source on a PC? Is there something in the Registry I can change that won't change after a reboot?

Thanks in advance.

  • Did you check the time zone on these machines? it is possible that it is set for the wrong time zone – stambata Jun 6 '16 at 15:12
  • Even if in same OU, they are in same ip subnet ? – yagmoth555 - GoFundMe Monica Jun 6 '16 at 15:22
  • The time is a few minutes to 20 minutes off, so it's not a time zone issue. The PCs having the problem are on a different subnet from ones that are not having this problem. All of them are on static IPs. I can't figure out what's telling these PCs to use local CMOS clock instead of a domain controller. – Patrick Ferrel Jun 6 '16 at 15:30
  • 1
    Are these virtual desktops or physical machines? Are the Domain Controllers physical or virtual? – joeqwerty Jun 6 '16 at 16:19
  • The desktops are physical. The domain controllers are virtual. – Patrick Ferrel Jun 6 '16 at 16:25
1

In the GPO's console: Computer Configuration\Administrative Templates\System\Windows Time Service\Time Providers\Enable Enable Windows NTP Client and Enable Windows NTP Server.

Double Click Configure Windows NTP Client settings, type NTP server Name

In case the GPO does not apply, you can enter it by script or by hand that way :

w32tm /config /syncfromflags:manual /manualpeerlist:”dc.domain.com” /reliable:yes /update

If you do it by hand;

Restart the servcie to make sure it sync.

net stop w32time && net start w32time

Validate all the config;

W32TM /query /status

w32tm /query /peers

w32tm /query /configuration 

The reason I offer to hardcode the time server is because you use static IP and some network use the DHCP option 42 to set the timeserver. (a option you can't use as you are in static)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.