1

I have AWStats running for two applications and for both no operating system is displayed. Instead only "unknown" is shown (100%). All the other stats are interpreted correctly, only the operating system makes problems.

Here my configuration:

  • AWStats v. 7.5 (same for 7.1)
  • Perl v. 5.16
  • IIS 7

Here a sample log, that is use as input with the log format above. To see it better, I inserted line breaks.

%time2              %other %other        %logname 
2016-05-11 00:31:51 W3SVC7 <Servername> 

   %other  %method %url  %other %other %logname %host      %other   
   <SIP>   GET     <URL> -      443    -        <ClientIP> HTTP/1.1 

   %ua                                                                  %other 
   Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 

   %referer %other   %code %other %other %bytesd %other %other
   <cookie> <domain> 200   0      0      55076   371    78

This is the log format defined for the application in a one liner:

LogFormat="%time2 %other %other %other %method %url %other %other %logname %host %other %ua %other %referer %other %code %other %other %bytesd %other %other"

And this the log entry

2016-05-11 00:31:51 W3SVC7 <Servername> <SIP> GET <URL> - 443 - <ClientIP> HTTP/1.1 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - >cookie> <domain> 200 0 0 55076 371 78

The same applied when I change Windows to Linux, the OS versions or other parameters. Even for another format with space instead of plus and sourrounded by ", I get the same result.

This is my config file for one of the apps, the other is nearly the same:

LogFile="D:\Logs\AWstats\...\u_ex%YY-24%MM-24%DD-24.log"
LogType=W
LogFormat="%time2 %other %other %other %method %url %other %other %logname %host %other %ua %other %referer %other %code %other %other %bytesd %other %other"
LogSeparator=" "
SiteDomain="..."
HostAliases="... localhost 127.0.0.1"
DNSLookup=2
DirData="D:\Inetpub\awstats\data\..."
DirCgi="/cgi-bin"
DirIcons="/icon"
AllowToUpdateStatsFromBrowser=0
AllowFullYearView=3
EnableLockForUpdate=0
DNSStaticCacheFile="dnscache.txt"
DNSLastUpdateCacheFile="dnscachelastupdate.txt"
SkipDNSLookupFor=""
AllowAccessFromWebToAuthenticatedUsersOnly=0
AllowAccessFromWebToFollowingAuthenticatedUsers=""
AllowAccessFromWebToFollowingIPAddresses=""
CreateDirDataIfNotExists=0
BuildHistoryFormat=text
BuildReportFormat=html
SaveDatabaseFilesWithPermissionsForEveryone=0
PurgeLogFile=0
ArchiveLogRecords=0
KeepBackupOfHistoricFiles=0
DefaultFile="index.aspx start.aspx index.php index.html"
SkipHosts="127.0.0.1 ..."
SkipUserAgents="REGEX[^check_http\/] REGEX[Yinsbot]"
SkipFiles=""
SkipReferrersBlackList=""
OnlyHosts=""
OnlyUserAgents=""
OnlyUsers=""
OnlyFiles=""
NotPageList="css js class gif jpg jpeg png bmp ico rss xml swf dc"
ValidHTTPCodes="200 304"
ValidSMTPCodes="1 250"
AuthenticatedUsersNotCaseSensitive=1
URLNotCaseSensitive=1
URLWithAnchor=0
URLQuerySeparators="?;"
URLWithQuery=0
URLWithQueryWithOnlyFollowingParameters=""
URLWithQueryWithoutFollowingParameters=""
URLReferrerWithQuery=0
WarningMessages=1
ErrorMessages=""
DebugMessages=0
NbOfLinesForCorruptedLog=50
WrapperScript=""
DecodeUA=0
MiscTrackerUrl="/Scripts/awstats_misc_tracker.js"
LevelForBrowsersDetection=2
LevelForOSDetection=2  
LevelForRefererAnalyze=2  
LevelForRobotsDetection=2   
LevelForSearchEnginesDetection=2
LevelForKeywordsDetection=2     
LevelForFileTypesDetection=2   
LevelForWormsDetection=0       
UseFramesWhenCGI=1
DetailedReportsOnNewWindows=1
Expires=0
MaxRowsInHTMLOutput=1000
Lang="auto"
DirLang="./lang"
ShowMenu=1                  
ShowSummary=UVPHB
ShowMonthStats=UVPHB
ShowDaysOfMonthStats=VPHB
ShowDaysOfWeekStats=PHB
ShowHoursStats=PHB
ShowDomainsStats=PHB
ShowHostsStats=PHBL
ShowAuthenticatedUsers=1
ShowRobotsStats=HBL
ShowWormsStats=0
ShowEMailSenders=0
ShowEMailReceivers=0
ShowSessionsStats=1
ShowPagesStats=PBEX
ShowFileTypesStats=HB
ShowFileSizesStats=0    
ShowDownloadsStats=HB   
ShowOSStats=1
ShowBrowsersStats=1
ShowScreenSizeStats=1
ShowOriginStats=PH
ShowKeyphrasesStats=1
ShowKeywordsStats=1
ShowMiscStats=a
ShowHTTPErrorsStats=1
ShowSMTPErrorsStats=0
ShowClusterStats=0
AddDataArrayMonthStats=1
AddDataArrayShowDaysOfMonthStats=1
AddDataArrayShowDaysOfWeekStats=1
AddDataArrayShowHoursStats=1
IncludeInternalLinksInOriginSection=0
MaxNbOfDomain = 10
MinHitDomain  = 1
MaxNbOfHostsShown = 10
MinHitHost    = 1
MaxNbOfLoginShown = 10
MinHitLogin   = 1
MaxNbOfRobotShown = 10
MinHitRobot   = 1
MaxNbOfDownloadsShown = 10
MinHitDownloads = 1
MaxNbOfPageShown = 10
MinHitFile    = 1
MaxNbOfOsShown = 10
MinHitOs      = 1
MaxNbOfBrowsersShown = 10
MinHitBrowser = 1
MaxNbOfScreenSizesShown = 5
MinHitScreenSize = 1
MaxNbOfWindowSizesShown = 5
MinHitWindowSize = 1
MaxNbOfRefererShown = 10
MinHitRefer   = 1
MaxNbOfKeyphrasesShown = 10
MinHitKeyphrase = 1
MaxNbOfKeywordsShown = 10
MinHitKeyword = 1
MaxNbOfEMailsShown = 20
MinHitEMail   = 1
FirstDayOfWeek=1
ShowFlagLinks=""
ShowLinksOnUrl=1
UseHTTPSLinkForUrl=""
MaxLengthOfShownURL=256
HTMLHeadSection=""
HTMLEndSection=""
MetaRobot=0
Logo="awstats_logo6.png"
LogoLink="http://www.awstats.org"
BarWidth   = 260
BarHeight  = 90
StyleSheet=""
color_Background="FFFFFF"       # Background color for main page (Default = "FFFFFF")
color_TableBGTitle="CCCCDD"     # Background color for table title (Default = "CCCCDD")
color_TableTitle="000000"       # Table title font color (Default = "000000")
color_TableBG="CCCCDD"          # Background color for table (Default = "CCCCDD")
color_TableRowTitle="FFFFFF"    # Table row title font color (Default = "FFFFFF")
color_TableBGRowTitle="ECECEC"  # Background color for row title (Default = "ECECEC")
color_TableBorder="ECECEC"      # Table border color (Default = "ECECEC")
color_text="000000"             # Color of text (Default = "000000")
color_textpercent="606060"      # Color of text for percent values (Default = "606060")
color_titletext="000000"        # Color of text title within colored Title Rows (Default = "000000")
color_weekend="EAEAEA"          # Color for week-end days (Default = "EAEAEA")
color_link="0011BB"             # Color of HTML links (Default = "0011BB")
color_hover="605040"            # Color of HTML on-mouseover links (Default = "605040") 
color_u="FFAA66"                # Background color for number of unique visitors (Default = "FFAA66")
color_v="F4F090"                # Background color for number of visites (Default = "F4F090")
color_p="4477DD"                # Background color for number of pages (Default = "4477DD")
color_h="66DDEE"                # Background color for number of hits (Default = "66DDEE")
color_k="2EA495"                # Background color for number of bytes (Default = "2EA495")
color_s="8888DD"                # Background color for number of search (Default = "8888DD")
color_e="CEC2E8"                # Background color for number of entry pages (Default = "CEC2E8")
color_x="C1B2E2"                # Background color for number of exit pages (Default = "C1B2E2")
LoadPlugin="tooltips"
LoadPlugin="decodeutfkeys"
LoadPlugin="timezone CET"
LoadPlugin="geoipfree"
ExtraTrackedRowsLimit=500

The file cgi-bin/lib/operating_systems.pm has read-rights like the other .pm files in the lib directory.

  • I'd guess the dumpster fire that is the IE11 user agent string (Mozilla Trident Like-Gecko? What the hell, Microsoft?!) is confusing to it. – ceejayoz Jun 7 '16 at 13:37
  • The problem is not that IE11 is not recognized as IE11, it is that "Windows+NT+6.1" is not recognized as the Windows operating system. I only geht unknown operating systems. – Lukas Jun 8 '16 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.