2

I have an interesting issue. let me describe my setup:

I have a server at home that serves as my Virtual Machine Host. All of the computers here are VM Computers, I don't think that makes a difference because they are all Bridged to the router and are individually accessible to the network.

I have setup a Ubuntu server setup as a vm with just a SSH Server publically accessable to act as a gateway to the rest of my network which is private (I have port forwarded through the router port 22) lets call this the SSH-HOST.

I have a Windows 10 VM that i would like to RDP into. I have configured the Remote Settings inside Windows to allow Remote Connections. Additionally for troubleshooting I have turned off the Windows Firewall. Lets call this computer WIN-PC

Lastly i have a Ubuntu Desktop VM setup and running, I have Xrdp setup and working so that i can remote into this linux vm easily via RDP. Lets call this computer UBUNTU-PC

  1. From inside my network I can RDP to WIN-PC and UBUNTU-PC using Their ip address or their DNS host name (setup on the router).

  2. From outside my network, if I setup port forwarding on the router, I can RDP into the WIN-PC AND UBUNTU-PC using the public IP or my domain name for my network (Have to reconfigure the router to test both setups).

  3. I can ping the WIN-PC AND UBUNTU-PC computer and get reply's when i'm inside the network.

So, I believe that the RDP is setup correctly and working properly. What i am trying to do is avoid the port forwarding 3389 on the router so I can RDP from external. There are a couple reasons for why I want this, but I wont go into that here.

I came across the idea of SSH Tunneling a while ago and have been successful in setting up many SSH Tunnels into windows and linux machines in the past.

From work or school (outside my network) Using Putty on windows, I create a local tunnel, Connect to the SSH-HOST and then I can RDP into the UBUNTU-PC just fine, so my SSH tunnel is setup properly in putty. But leaving everything else the same (just changing the local Tunnel Destination IP) Connecting to the WIN-PC via RDP just spins and then eventually says that RDP was unable to connect to the remote computer.

I have been working for about a week to test where I'm failing. I have run putty from school, from work, and additionally setup a SSH tunnel on my iphone using serverauditor and then run the RDP app which also works to gets me into the Ubuntu-PC but doesn't connect to the Win-PC.

Doing all of this I can always get into the UBUNTU-PC computer, so i know things are open. but the WIN-PC is not connecting externally through the SSH Tunnel.

So this is where I'm stumped. What else should i try?

  • This is a good post, it explains exactly what you're trying to do but does leave out a few details that would be useful. Please list the ssh commands you're trying to use, as presumably you're trying to port forward with ssh. Also, when you say you can rdp to your win 10 vm from that subnet, do you mean you can connect to it from the hypervisor or definatley from an entirely separate machine? – Alex Berry Jun 8 '16 at 15:17
  • Sure, inside the network i would be connecting from my laptop (or iphone RDP app) so im not using the VM Hypervisor to view the Computer. – Kraczekj Jun 8 '16 at 15:50
  • OK, and what ssh command are you using from outside your connection to tunnel RDP? (you can replace your public IP with x.x.x.x). In addition, once the ssh session is connected, what rdp command are you using? – Alex Berry Jun 8 '16 at 15:51
  • For the SSH Commands, inside putty for windows (on school computer, or laptop, or work computer external to my network) goo.gl/photos/xMHwpycQ2Fg6RK1Z8 here are the pics trying to connect to the Win Computer - in putty if i change the local IP to that of the UBUNTU-PC it connects immediately. – Kraczekj Jun 8 '16 at 16:06
  • It seems you have it set up correctly. I'm not sure where the windows machine would see source packets coming from, I imagine it should see them come from your linux machine but it could be something to do with windows only accepting connection requests from within the same subnet. Could you try and disable windows firewall and test again? – Alex Berry Jun 9 '16 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.