0

I am attempting to use WDS to deploy a custom Windows 10 Education image on to my school's computers. I have a VM running Windows Server 2012 R2. When I add a custom install.wim Windows 7 image (created using a reference computer and imagex) everything works fine, but when I attempt to use a Windows 10 image, any computer I attempt to PXE says "No images are available". If I restart the server at this point, the Server Manager shows a number of errors and the WDS service is unable to start. The problem is only resolved by deleting the Windows 10 image (install.wim) from the server. Disabling it results in the "No images are available" still appearing on any machine attempting to PXE.

I have tried rebuilding the VM, but the result was the same. The server worked fine until the custom Windows 10 image is added, but then it broke (showed "No images are available"). I have also tried using a different reference computer, but after 3 different computers, nothing changed. I have tried installing Windows 10 to the reference computer and immediately capturing it with imagex (still in OOBE), but again the same problem. I also tried using a Windows 10 install.wim straight from the install disk, and that worked (but was not customized).

My conclusions:

  • The problem is not with the WDS server, because it is a new VM and I rebuilt it multiple times.
  • The problem can't be with the physical reference computer, because all 3 very different machines had the same problem.
  • The issue certainly is not just a Windows 10 problem, because the install.wim from the Windows 10 disk worked.
  • The problem is caused by loading a specific install.wim into the server, so some attribute of that file must be causing the issue.

The only thing I can think of is maybe the imagex flash drive has something wrong with it, but I feel that that is unlikely.

What would cause a captured install.wim to break the WDS service when the image file is added? What about the image file would make the message "No images are available" be displayed, even when there are other, perfectly acceptable images on the server?

  • 1
    what does the wds service log show as an error. What did you use to customize the image? is this solely WDS or is this part of a deployment toolkit task sequence? – Jim B Jun 8 '16 at 17:50
  • The log just said that the WDS Service cannot start. I tried to start it manually and it failed. To customize the image, I installed Windows 10 on the reference computer, put it into system Audit mode, and installed some software (Chrome, office 2016, Java, etc). However, when that failed, I made a second image with literally nothing on it (just Windows 10). All Windows 10 images I tried to use failed (except the install.wim straight from the disk). The server is solely WDS. – User45648898 Jun 8 '16 at 19:28
  • so your reference computer was physical? Which version of windows and and which ADK did you use (since your not using the deployment tool) – Jim B Jun 8 '16 at 19:35
  • @User45648898 Did you use sysprep on the computer before capturing and aldo are you using a Windows 10 boot image? I know that you said that a stock Win10 install images works but I wanna cover all of the bases. I would try using a stock Win10 boot image from the DVD/ISO that came from MS. EDIT: Also, you might wanna try using MDT 2013 U2 as it has Windows 10 deployment support and might fit your needs. It is free also. – Elliot Labs LLC Jun 9 '16 at 12:42
  • So it turns out that sysprep was the issue after all. I had created some sysprepped images, but I guess I only added them along side other, non-sysprepped images (which broke the server). When I added just the sysprepped image by itself, everything worked. I still don't understand why a single bad install.wim could break the entire server and make none of the images work until it is deleted, but at least the problem is solved. Elliot Labs, post your solution at the answer so I can mark it. Thank you! – User45648898 Jun 9 '16 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.