1

Currently having an issue on a server that is impacting all users.

When any user logs in they are brought to a temp profile. I have tried all of the fixes in regards to the registry profile list, as .bak users are created, but none of that is solving my problem.

-I have tried the fix involving deleting the the temp profile entry in the registry, Deleting it's GUID entry in the registry, and resetting the state to 0 in the registry entry for the correct profile. I have repeated the previous step and deleted all the temp users generated.

-I have tried to delete the SMQ files from the default user profile and then reset the child permissions on the C:\Users\Default folder...as the login service would fail to login any user other than the admin user. This allowed me to login as any user again but did not resolve the temp profiles.

The only thing I can go on is

Remote Desktop Services could not obtain a user profile disk for the user account with a SID of ***. Verify that the user profile disk location is accessible, the server's computer account has read and write permissions to it, and that the location has a user profile disk template file present. The error code is 0x43.82

The Remote Desktop Connection Broker server could not enumerate the targets for the provider named NULL from the database. Pooled virtual desktop collection name: NULL Error: Logon to the database failed.

I checked the location that the users UPDs are stored in. Administrators have full control of the directory and users have read&write, execute, list directory. This folder is not itself shared. Should it be?

Please help. Thanks in advance

  • 1
    I have tried all of the fixes in regards to the registry profile list - Are we supposed to just intuitively know what that means? Tell us exactly what "fixes" you've tried. Also, have you verified what the error message is telling you regarding permissions and the template? – joeqwerty Jun 9 '16 at 11:50
  • @joeqwerty added information – Pretzel Jun 9 '16 at 14:37
1

I Fixed it.

I had to give the folder the UPDs were stored in Share permissions for "read" for everyone. Also had to add "read & execute, list directory items" for everyone in the folders security settings.

1

The solution is provided in the error message:

Verify that [...]the server's computer account has read and write permissions to it[...]

You don't have to give everyone the read permission on the share nor on the directory, but all your session-hosts must be able to read and write in the directory containing the UPDs.

Personally, I add my session hosts to a security group and give this group read/write permissions on the UPD share/directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.