0

I have a server with 2 NICs.

NIC1: direct cable from modem (ISP provides 8 public IPs). NIC2: to the internal network.

Software is Hyper-V Server.

Created 2 Virtual Switches in Hyper-V, one with NIC1, one with NIC2.

Installed pfSense, attached both, and marked NIC1 as WAN, so that anybody who is using NIC2 (internal, on the box, or via a physical switch) has to go through pfSense.

However the issue is now that the Hypervisor itself still gets a public IP. I can perfectly protect that NIC by marking it as public in Hyper-V, no door is still better than a perfectly sealed door!

In ESXi this is easy to configure, there you can passthrough NIC1 with DirectPathIO to pfSense, and then the host doesn't even see it anymore, but that's not available in Hyper-V (only SRV-IO, but that's enabled and doesn't remove it from the host).

Any help on this?

1

Uncheck "Share this network with management OS" in the switch configuration if you don't want the management OS to use that network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.