0

Currently I am trying to set up let's encrypt on my Ubuntu 16.04 server. I am using Apache 2.4.18 as my webserver and also passenger.

I am using the following command to generate my certs and to configure the apache files:

letsencrypt -d example.com --apache

https://certbot.eff.org/#ubuntuxenial-apache

But letsencrypt gives me the following error message:

Currently, we only support configuration with one vhost per file in apache2.conf

The problem is that I only have one vhost configured. I didn't change too many things in the file, but that may be the problem.

I only insert the vhost tag (which only appears once in my file)

<VirtualHost x.x.x.x:80> # I am not using wildcard but my IP instead
    ServerName www.mydomain.com

    Alias /sub /var/...
    <Location /sub>
        PassengerBaseUri /sub
        PassengerAppRoot /var/..
    </Location>
    <Directory /var/..>
        Allow from all
        Options -MultiViews
        Require all granted
    </Directory>
</VirtualHost>

Do you need more information from my .conf file?

I have to admit that I am new to such things and have no idea where my mistake is. I do not include other files and I checked all my vhosts with

apache2ctl -S

and there was only one. I believe that the error message isn't 100% correct and the reason why letsencrypt fails is something different than my vhost.

Any ideas?

1

There are various methods to verify domain ownership. You may want to use a different method of verifying domain ownership such as --webroot or --standalone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.