2

On a Windows 2012 R2 server used as remote desktop, we installed Microsoft Office 2013 64-bit.

Several weeks later, an accounting software was installed. This required Microsoft Office 32-bit (we tested with 64-bit: failed).

So I uninstalled the 64-bit version, and installed the 32-bit version.

Word and Excel work well.
But Outlook display an annoying error message when launched (but works flawlessly).
The message is not displayed when Outlook is ran as an administrator (being admin is not sufficient, we have to right-click and ask to run as administrator).

  • when someone run Outlook, we first have the usual blue rectangle with "Outlook" written in the middle
  • then we immediatly have a small window titled "Microsoft Office 64-bit Components 2013" with a progress bar stating "Please wait while Windows configure Microsoft Office 64-bit Components 2013"
  • 1 or 2 second later an error pop-up appear indicating "Error 2503: an internal error occured. Contact Microsoft support blahblah"
  • we click on "Ok"
  • we immediatly have the same pop-up but with error 2502
  • we click on "Ok"
  • Outlook now run correctly, until the next time we run it

Each time someone run Outlook we have this exact same scenario.
Steps 1 and 2 occur even when ran with administrator privileges.

I uninstalled/reinstalled the 32-bit version.
I did a repair install.

I deleted a vestigal C:\Program Files\Microsoft Office\.
It is recreated if we run Outlook with administrator privileges.
The error is the same with or without this folder. I even tested with full rights for everyone on this folder and its content.

Any idea to solve this problem?

  • How about doing what the message says - contacting Microsoft support? – Jenny D Jun 15 '16 at 5:28
  • 1
    Why so many VTCs? If it's used as a remote desktop host, it's a perfectly reasonable business pratice to install Office on a server system. – Massimo Jun 15 '16 at 18:44
4

This is a know issue. Office 2013 32 bit on a 64 bit OS need the Windows Search service.

"Please wait while Windows Configures Microsoft Office 64-bit Components 2013" message when you start Outook 2013 | https://support.microsoft.com/en-ca/kb/2643974

Cause This issue occurs when the following conditions are true:

- The 32-bit version of Office is installed on a 64-bit version of the operating system.
- The Windows Search Service is not installed.

Windows Server 2012

Start Server Manager.
Click Manage, and then click Add Roles and Features.
On the Before You Begin page, click Next.
On the Installation Type page, select Role-based or Feature-based Installation, and then click Next.
On the Server Selection page, select the server or virtual hard disk on which you want to install the Windows Search Service.
On the Features page, select Windows Search Service, and then click Next.
On the Confirmation page, verify that Windows Search Service is listed, and then click Install.

 

If you prefer not to use or install the Windows Search Service, you can disable indexing in Outlook. To do this, follow these steps:

Exit Outlook.
Start Registry Editor. To do this, use one of the following procedures, as appropriate for your version of Windows.
    Windows 8: Press Windows Key + R to open a Run dialog box. Type regedit.exe and then press OK.
    Windows 7, Windows Server 2008, or Windows Server 2012: Click Start, type regedit.exe in the search box, and then press Enter. 
In Registry Editor, locate and then click the following registry subkey: 

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search
Point to New on the Edit menu, and then click DWORD (32-bit) Value.
Type PreventIndexingOutlook, and then press Enter.
Right-click PreventIndexingOutlook, and then click Modify.
In the Value data box, type 1, and then click OK.
On the File menu, click Exit to exit Registry Editor.

The error stops immediatly after Windows Search Service is installed.
If you don't use the Windows Search Service, just disable it in the service console.

  • I didn't found this MS KB, nor anything on Google. Many thanks! – Gregory MOUSSAT Jun 23 '16 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.