0

Long-time Unix sysadmin, just getting started in the Windows world, here:

I have a Windows 7 Enterprise machine. A recent system update must have gone pear-shaped, because now when I try to log in as DOMAIN\user, I get "Trust relationship has been lost with domain controller".

I gather that this means that the workstation is failing to authenticate properly to the Active Directory domain controller. Normally, I'd log in as the local admin and reconnect. But I don't know the local administrator password, and I never set up a local account for myself.

I've created a system recovery disk and tried to restore from the save points created before Windows updates. None of them work: they all restore properly, then fail with "Unknown error". I've tried half a dozen save points going back to early May.

Any ideas on how to get this machine reconnected? I have physical access to the machine; I have administrative access on the domain controller. I don't have Windows install disks (do those still exist anymore?). I don't have the password to any local accounts, though I can boot from a repair CD and get access to local files.

Thanks,

1 Answer 1

1

The trust issues usually happen with laptops that have not contacted a domain controller for longer than 30 days (the machine password is not renewed).

Your best option now would be to reset the local administrator password with something like ntpasswd or the trinity rescue kit, and then rejoining the machine to the domain.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.