10
ubuntu@ip-172-31-21-62:~$ sudo service rabbitmq-server start
 * Starting message broker rabbitmq-server                                        [ OK ]
ubuntu@ip-172-31-21-62:~$ sudo service rabbitmq-server  stop
 * Stopping message broker rabbitmq-server                                                * message broker already stopped
                                                                              [ OK ]
ubuntu@ip-172-31-21-62:~$ sudo service rabbitmq-server status
Status of node 'rabbit@ip-172-31-21-62' ...
Error: unable to connect to node 'rabbit@ip-172-31-21-62': nodedown

DIAGNOSTICS
===========

attempted to contact: ['rabbit@ip-172-31-21-62']

rabbit@ip-172-31-21-62:
* connected to epmd (port 4369) on ip-172-31-21-62
* epmd reports: node 'rabbit' not running at all
              no other nodes on ip-172-31-21-62
* suggestion: start the node

current node details:
- node name: 'rabbitmq-cli-19082@ip-172-31-21-62'
- home dir: /var/lib/rabbitmq 
- cookie hash: Zoi/1N8mjGUsELj8Z7yzoA==

ubuntu@ip-172-31-21-62:~$

I tried to reset it using sudo rabbitmqctl reset and sudo rabbitmqctl force_reset both did not work.

8

remove /var/log/rabbitmq/* and start it back

from : https://groups.google.com/forum/#!topic/rabbitmq-users/w0aJNmfz1N8

  • 1
    You should add the details here so we don't have to go dig through a google group. Also, that link might not always be available – Charlie Martin May 3 '18 at 14:46
  • So after removing sudo rm -rf /var/log/rabbitmq/* , I started sudo service rabbitmq-server start and rabbitmqctl start_app. It worked, thanks! – radtek May 16 '18 at 15:15
1

empd report to my knowledge is a part of OTP(Erlang) peer recognition for rabbitmq, installed as a dependency while installing rabbitmq. You can check the erl_crash.dump file to check the reason for the crash and act accordingly.

If you are not able to make anything out of the crash report, you can simply change the rabbitmq.config to default value. I got my rabbitmq like this. You will find the default settings in rabbitmq.congif.example file. Once you are done with this, restart the rabbitmq server and it should work.

0

It was selinux in my case, have a look what is in rabbit log file /var/log/rabbirmq/(nodename@host).log if it is anything about ports then it might be selinux

0

In my case it was a problem with the service not started properly.

After trying the accepted solution I just an additional

service rabbitmqserver restart

and it worked. After that, the second node connected without problems again to the other node.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.