1

So for 1,5 years now I was running a DigitalOcean droplet without any problems. did apt-get upgrade several times, changed some things - all fine! Last night suddenly all my alarms went off and my whole server was down. I tried to SSH connect - not working. After a hard power cycle I could at least open a in-browser console in the DigitalOcean panel.

During bootup the machine is stuck for 120 seconds "waiting for a network module". I then tried to just do ifdown eth0 && ifup eth0 but it always returned failed to bring up eth0. I tried many things by now and also the DigitalOcean support ran out of ideas. They made me do some shell cmds and screenshot the output, please see these attached. I really don't know what to do anymore. this happened out of nowhere, without me changing anything for weeks.

strace ifup

Some commands: /etc/network/interfaces

ip addr

I also compared the /etc/network/interfaces config with another droplet and it looks pretty much the same. After many tickets the support concluded:

We've exhausted all troubleshooting capacities for the platform side of things. All testing indicates that the packets are able to be properly routed to the droplet, but the droplet is not acknowledging the packets returning for it. The missing routes indicate that this is likely an issue with the network initialization process/scripts.

I really hope someone can help here. no ideas left. Thanks in advance!


UPDATE:

  • permissions of /etc/network/interfaces: -rw-r--r--
  • Ubuntu 14.04 LTS x64
  • dmesg: hard to tell, cant scroll in this stupid in-browser console.
  • ip addr flush dev eth0 and then ip link set dev eth0 up ... didn't do anything. Do I have to reboot?
  • lshw -class net: see screenshot below: lshw

UPDATE 2:

  • Does commenting out the "up"-line in the interface config change anything? - no
  • dmesg | less: ok this works. what am I looking for?
  • grep VIRTIO_NET /boot/config-$(uname -r) - outputs: CONFIG_VIRTIO_NET=y.
  • lsmod|grep virtio_net - didnt return anything! sorry.
  • Can you show the output of ip addr list , also the permissions on /etc/network/interfaces. Is NetworkManager running by any chance? Which debian derivative is running on the droplet? Oh and what does dmesg tell you. – Valentin Bajrami Jun 13 '16 at 13:03
  • You should also try to use ip command instead if ifconfig which is deprecated. Try using ip addr flush dev eth0 and then ip link set dev eth0 up – Valentin Bajrami Jun 13 '16 at 13:16
  • I guess there is something wrong with the card or the driver. Try finding something with dmesg, lsmod, lspci and/or lshw -class net – Silent-Bob Jun 13 '16 at 13:46
  • ip addr list output is already in my post! I will answer the remaining stuff in my post! – Patrick DaVader Jun 13 '16 at 13:48
  • @PatrickDaVader Did ip addr link dev eth0 up bring the interface up? What message did it return? – Valentin Bajrami Jun 13 '16 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.