0

For whatever reason I can't get my virtual disks to show up on any of my RHEL 7.X guests (libvirt + KVM). The XML is configured just like my other guests so I know it isn't an issue on that end. It almost seems like my VMs are missing a SCSI driver or something but it's difficult to tell.

/proc/scsi/scsi has no entries in it and none of the disks are in /dev or /dev/disk/by-*. I'm not exactly sure what I should be looking for, so if anyone has any ideas about why this would happen please let me know.

| improve this question | | | | |
  • Try running modprobe virtio_scsi and see... – Martian Jun 15 '16 at 11:07
  • Tried this but it didn't give any output. Tried in verbose mode as well but I got nothing from it. If that driver was missing I assume I'd get an error. How can I verify that this driver is loaded and working properly? – sirstancake Jun 15 '16 at 19:31
  • What does lsblk say? The disks could be either virtio (showing as /dev/vdX) or virtio-scsi ones (which would show as /dev/sdX). Could you post the xml? We the VM installed using anaconda or created from an image another way? – Martian Jun 21 '16 at 9:35
0

I see. If these are virtio only, and not virtio-scsi devices, I can reproduce in a VM. I have opened a Bugzilla at https://bugzilla.redhat.com/show_bug.cgi?id=1348664.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.