0

As Apple keeps making "improvements" to the LDAP that comes with OSX (i.e. keeps breaking it on each update), I had to do my own installation of openldap, which worked fine on Maverick and Yosemite (openldap 2.4.39). However, when I tried to launch it again today (upgraded to El Capitan 10.11.5 a while back) it did not want to start up again. Google searches suggested to upgrade brew and reinstall:

%> brew update && brew upgrade
%> brew reinstall homebrew/dupes/openldap --with-berkeley-db

After this, I had a fresh openldap 2.4.43 installation. Unfortunately that did not do the trick. openldap now stops again right after launching:

575fdffe /usr/local/etc/openldap/slapd.conf: line 53 (database  bdb)
Unrecognized database type (bdb)
575fdffe /usr/local/etc/openldap/slapd.conf: line 53: <database> failed init (bdb)
575fdffe slapd destroy: freeing system resources.
575fdffe slapd stopped.

Googling for this showed tips that one needs to uncomment some lines in the config. In slapd.conf I can see the following config:

# Load dynamic backend modules:
# modulepath    /usr/local/Cellar/openldap/2.4.43/libexec/openldap
# moduleload    back_bdb.la
# moduleload    back_hdb.la
# moduleload    back_ldap.la

However, the referenced folder does not exist. Any ideas anyone? Oh... and answers in "complete idiot" style would be appreciated as I know way to little about sys admin in general and specifically ldap. I'm "just" a developer. THANKS!

  • You break out of the box with the osx, would be easier to run a vm to test out setting – yagmoth555 Jun 14 '16 at 11:42
1

So it seems that the "--with-berkley-db" tag is not valid anymore. The current command is:

brew reinstall openldap --with-berkeley-db@4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.