I'm using this video tutorial to try and install ColdFusion 9 with MAMP Pro on my Macbook, for development purposes. It works when installing CF8; but with both the 32 bit and 64 bit versions of CF9, I can't get it working.

I reach the 19 minute mark of the video and add index.cfm to the DirectoryIndex directive, then restart the services in MAMP Pro. Apache fails to stop, requiring a force-quit (not something I did manually, MAMP asked if I wanted it to try to force-quit, I said yes, and it seemed to do the job) and now when I try to start Apache I get the message:

Apache wasn't able to start. Please check log for more information.

This is what I see in the console log:

Syntax error on line 1131 of /Users/adam/Library/Application Support/living-e/MAMP PRO/httpd.conf:
Cannot load /Applications/ColdFusion9/runtime/lib/wsconfig/1/mod_jrun20.so into server: cannot create object file image or add library

The mod_jrun20.so file mentioned in the error does exist at the indicated location.

The only other thing that has changed since this was working for me with CF8 was that I upgraded from Leopard to Snow Leopard. I did uninstall and re-install MAMP Pro after the Snow Leopard upgrade, though.

Anyone have any ideas on how I can get this working?


Try unzipping the wsconfig.jar file (found in {cf_root}/runtime/lib/wsconfig.jar). Therein you should find the stock 32-bit version of mod_jrun.so connector. Try using that one to replace the one that Apache is having trouble loading. That seems to have worked for other people who have had this problem

  • I ended up getting the correct file out of the 32 bit CF9 installer application (browsing into it in Finder); but this was the solution. – Adam Tuttle Oct 27 '09 at 18:19
  • Here's a screencast I put together to show how to fix this: fusiongrokker.com/post/… – Adam Tuttle Oct 28 '09 at 15:05

That happened to me as well when I installed CF9 on MAMP (not MAMP Pro) in multi-server mode (I already had CF8 installed and then I generated the EAR for CF9 and added it to JRun). In my case, I'm pretty sure the reason was that I tried to install the 64 bit version of CF9. I read somewhere that Apache that comes in MAMP only runs in 32 bit mode and therefore can't load the 64-bit version of mod_jrun.so. When I uninstalled CF9 (and also made sure that mod_jrun.so was deleted) and re-installed the 32-bit version, all was well. I'm not sure this will help you, though, since you stated that you're also having this problem with the 32-bit version. But I guess I would make sure that mod_jrun.so is deleted before re-installing. Good luck!


I've seen that before... Sometimes, for whatever reason, the mod_jrun20.so file is corrupt. Try replacing it with the mod_jrun20.so file from another machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.