A critical security update came out a while ago, that I have been unable to install. I've spent the better part of today trying to figure this one out and I'm stumped. I've tried using the automatic update, as well as manually downloading the update from the Microsoft website.

My systems are running Windows Server 2008 Enterprise x64. This same update is failing on three independent and isolated servers (the only Windows Server 2008 servers I have access to).

Whenever the system attempts the update I get the following error:

Installer encountered an error: 0x8007000d The data is invalid.

And it creates an companion event log seen below:

- System 

  - Provider 

   [ Name]  Microsoft-Windows-WUSA 
   [ Guid]  {09608c12-c1da-4104-a6fe-b959cf57560a} 

   EventID 3 

   Version 0 

   Level 2 

   Task 0 

   Opcode 0 

   Keywords 0x8000000000000000 

  - TimeCreated 

   [ SystemTime]  2009-10-26T18:00:08.659Z 

   EventRecordID 11 


  - Execution 

   [ ProcessID]  6732 
   [ ThreadID]  6592 

   Channel Setup 

   Computer server.example.com 

  - Security 

   [ UserID]  S-1-5-21-1868723478-1673120740-2095933981-27156 

- EventData 

  ErrorCode 2147942413 
  ErrorString The data is invalid. 
  CommandLine "C:\Windows\system32\wusa.exe" "C:\Users\admin\Desktop\Windows6.0-KB967723-x64.msu"

Does anyone have any ideas?

  • What is in the WindowsUpdate log in your windows directory? – Sim Oct 26 '09 at 20:46

Call Microsoft. Provided you have a licensed product, security cases are covered by their free support and is actually quite good.

| improve this answer | |
  • 1
    If you get a result from MS please post the solution here. – Sim Oct 26 '09 at 20:48

I would manually download the update (available here). Then close all running applications, especially antivirus apps, and then try executing the update. If that still fails, use the Contact Support link on the related KB page.

| improve this answer | |
  • Please note in my question I specifically stated I have already tried manually downloading the security update to be installed and it failed with the same error. I appreciate you pointing out the Contact link though. – TrueDuality Oct 29 '09 at 12:49

After contacting Microsoft, I got the problem resolved. Apparently there is a known issue for this specific update and Microsoft currently has plans to release a hotfix soon. In the mean time they recommend downloading the update automatically and installing it. The copy that I had downloaded was apparently corrupted resulting in the same error. After re-downloading it the install went fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.