1

I'm trying to setup backend servers with ssl between the LB and the Server (172.16.12.34 is hosting http and https on the standard ports)

backend test
        balance source
        option httpchk
        default-server fastinter 7000 inter 500 fall 2
        server server1 172.16.12.34:443 check
        server server2 172.16.12.34:443 check ssl
        server server3 172.16.12.34:80 check
        server server4 172.16.12.34:80 check ssl

and I get the following unexpected output in stats

          Status     LastChk
server1   4m2s DOWN  * L7TOUT in 500ms
server2   4m2s DOWN  * L7TOUT in 501ms
server3   4m4s UP    L7OK/200 in 2ms
server4   4m4s UP    L7OK/200 in 2ms

It seems to be doing all the checks in http only and ignoring the ssl keyword.

Is this an Haproxy bug or have I got my config wrong? Or could this be compiler options? It is haproxy 1.6.4. Until I compiled with openssl it complained about the ssl keyword.

0

I downloaded 1.6.5, compiling with openssl option and it works...

          Status     LastChk
server1   4m2s DOWN  * L7TOUT in 500ms
server2   4m4s UP    L7OK/200 in 1ms
server3   4m4s UP    L7OK/200 in 2ms
server4   4m2s DOWN  * L6RSP in 0ms

I can't see any bugs fixed that mention it so maybe the previous one didn't compile quite right.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.