3

I am currently setting up a new server (Ubuntu LTS) and I have to use the VMware console form a Windows 10 PC to do so. I am used to use PuTTY and I find the VMware console very inconvenient.

What I would like to achieve is that the console would behave a bit more like common windows, like

  • it accepts keyboard input as soon as the window gets the focus, without needing to click into the black area first
  • it does not catch the mouse (not at all is ok, I don’t need a mouse in the console)
  • copy-paste using Windows’ clipboard (especially pasting passwords) would be fine, but is optional

I wantet to install the VMware tools to get this working and I am not yet sure if they are installed properly, but I guess (and also got first answer already) like yes. However the VMware console still behaves as before. Is there a way to change this behaviour? (Perhaps some vSphere configuration option just to disable mouse in the console at all, so that it just remains on my desktop?)

Clearly, getting the SSH dæmon to work will be my next step, however I would like to know if I can get the console to work this way, too.

2

What you want is not completely possible.

Regarding the keyboard and the mouse you have these options:

  • If you have VMware tools installed and an X-session is running the console will grab the mouse and the keyboard as soon as the mouse hovers over the console.

  • If you don't have an X-session running you will have to click into the console, regardless if the VMware tools are running or not.

copy&paste is disabled by default, but you can enable it for the VM:

  1. Log in to a vCenter Server system using the vSphere Client and power off the virtual machine.
  2. Select the virtual machine and click the Summary tab.
  3. Click Edit Settings.
  4. Navigate to Options > Advanced > General and click Configuration Parameters.
  5. Click Add Row.
  6. Type these values in the Name and Value columns:
Name                            Value
isolation.tools.copy.disable    FALSE
isolation.tools.paste.disable   FALSE

(Source: KB1026437, still valid for current versions)

Alternatively you can add these lines to the .vmx file:

solation.tools.paste.disable = "false"
isolation.tools.copy.disable = "false"

My advice: Install the SSHd as the first package after the setup, it's a lot easier to work with.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.