2

Exchenge 2010 server is not finding GC server in the domain even the domain controler . All Domain controllers are Windows Server 2012 Std. In the atest.local forest I have 3 DC and all 3 are GC:

PS C:\Users\administrator.atest> get-adforest atest.local
ApplicationPartitions : {DC=ForestDnsZones,DC=atest,DC=local, DC=DomainDnsZones,DC=atest,DC=local,
                        DC=DomainDnsZones,DC=cot,DC=atest,DC=local}
CrossForestReferences : {}
DomainNamingMaster    : pdc2-v.atest.local
Domains               : {atest.local, cot.atest.local}
ForestMode            : Windows2003Forest
GlobalCatalogs        : {cot2-v.cot.atest.local, pdc2-v.atest.local, pdc3-v.atest.local}
Name                  : atest.local
PartitionsContainer   : CN=Partitions,CN=Configuration,DC=atest,DC=local
RootDomain            : atest.local
SchemaMaster          : pdc2-v.atest.local
Sites                 : {Default-First-Site-Name}
SPNSuffixes           : {}
UPNSuffixes           : {}

But on the Exchange 2010 side in the EventViewer I see the following message generated by ADTopology exchenge process:

Process STORE.EXE (PID=5740). Exchange Active Directory Provider has discovered the following servers with the following characteristics: 
 (Server name | Roles | Enabled | Reachability | Synchronized | GC capable | PDC | SACL right | Critical Data | Netlogon | OS Version) 
In-site:
cot2-v.cot.atest.local  CDG 1 7 7 1 0 1 1 7 1
pdc2-v.atest.local  CD- 1 6 7 0 0 0 1 7 1
pdc3-v.atest.local  CD- 1 6 7 0 0 0 1 7 1 

which means that DCs pdc3-v.atest.local and pdc2-v.atest.local are not identified by ADTopology process as a GC. Why?

Thank you.

0

You have 0 instead of 1 under 'SACL right' on the problem servers. This is an error condition that I've seen discussed in a few places, such as this technet blogpost.

I believe re-running Setup /PrepareAD should resolve that.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.