0

I just upgraded subversion 1.6.11 to 1.9.4-1 on RH 6.8, and it's working okay by itself. But my Trac 1.0 application can no longer see my svn repos. According to http://www.wandisco.com/svnforum/forum/opensource-subversion-forums/apache-subversion-1-8-support/73237-importerror-usr-lib64-libsvn_swig_py-1-so-0-undefined-symbol-pycapsule_import the easiest solution to my problem is to downgrade to subversion 1.8.13-1. Since I didn't do an svnadmin upgrade, I think it should be okay to downgrade.

To do the upgrade to 1.9, I added a /etc/yum.repos.d/wandisco-svn.repo file that looked like this:

[WandiscoSVN]
name=Wandisco SVN Repo
baseurl=http://opensource.wandisco.com/rhel/$releasever/svn-1.9/RPMS/$basearch/
enabled=1
gpgcheck=0

and did this:

sudo yum upgrade subversion mod-dav-svn subversion-python   

so to downgrade, I changed the baseurl line to svn-1.8 instead of svn-1.9

but when I do a

yum list subversion --showduplicates

all I see is this:

Installed Packages
subversion-python.x86_64    1.9.4-1         @WandiscoSVN
Available Packages
subversion-python.x86_64    1.9.0-rc1       WandiscoSVN
subversion-python.x86_64    1.9.0-rc2       WandiscoSVN
subversion-python.x86_64    1.9.0-rc3       WandiscoSVN
subversion-python.x86_64    1.9.0-1         WandiscoSVN
subversion-python.x86_64    1.9.1-1         WandiscoSVN
subversion-python.x86_64    1.9.2-1         WandiscoSVN
subversion-python.x86_64    1.9.3-1         WandiscoSVN
subversion-python.x86_64    1.9.4-1         WandiscoSVN

Even if I change the baseurl to svn-1.7, I still only see 1.9 choices, so I think it must not want to show me previous minor versions.

I took a guess and tried

sudo yum downgrade subversion-1.8.13-1

but I just got "No package subversion-1.8.13-1 available.

1) What to I have to do to downgrade to 1.8? I would really rather not uninstall and install (especially from binaries), because I tried that on an earlier attempt to upgrade to 1.9, and I ran into other dependency problems. Also, I'm not very good with Linux, and I'm afraid that would break the ldap authentication that someone who's since left the company set up for this.

2) Am I using the right baseurl for my wandisco-svn.repo? If not, how can I find the right one? On their site, I only see links to download the binaries, not how to configure a .repo. I found the .repo text I am using from various "how to install" examples, but none of the examples explain where they got the URL from.

0

Back up your data.

List the transaction with yum history and undo it with yum history undo

How to use yum history to roll back an update in Red Hat Enterprise Linux 6 , 7?

  • Thank you for responding. I tried this, but it failed (thanks for the warning to backup the data). Rather than try to figure out why the undo failed to work properly, I restored my vm back to the snapshot I took prior to the upgrade. There were only a few commits, so I saved those off before the restore, and then re-committed them. Now I am in a position to upgrade to 1.8.3. However, although my baseurl is pointing to opensource.wandisco.com/rhel/$releasever/svn-1.8/RPMS/$basearch, I am still only offered the option to install 1.9. Wish I could find the right repository to get 1.8. – kvarkel Jun 20 '16 at 23:07
  • You may have a cache of the newer version which yum will prefer. A brute force way of refreshing after repo changes is yum clean all; yum makecache – John Mahowald Jun 21 '16 at 18:33
  • You're right about the cache. We also had a proxy server rule that was not allowing us to access anything at wandisco except for 1.9. Thanks! – kvarkel Jun 21 '16 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.