0

OK, I'm about to drive down to Mexico and bust this server with a hammer.

Basically, the RAID 5 array is hosed, so we need to copy everything off it so we can rebuild the array. I have everything copied off the drive so far, EXCEPT for the .vhd for the file server. It's a 1TB file, and it as well as everything else is going onto a 3TB external drive.

The specific Robocopy command I'm using is: robocopy /s d:\ e:\MX03-HYPERV-P01 /b /eta /r:0

The exact error I'm getting is: 2016/06/16 17:54:17 ERROR 5 (0x00000005) Copying File d:\MX03-DC2012-P50\Win2K12R2.vhd Access is denied.

Now, I definitely have local admin. I also added myself to the Backup Operators group. I verified I have the backup permission via "whoami /priv". I also added my account explicitly to the folder I'm copying from, as well as the folder I'm copying to, and set it to replace permissions on sub-objects. I also took ownership of both directories (again, setting it on sub-objects).

Nothing's working, and I'm about to lose it. Also, hotfix KB979808 (https://support.microsoft.com/en-us/kb/979808) isn't applicable to this system, I've already tried it.

Now, to be clear, I was able to copy the rest of the vhd's without any issue, other than one. The vhd for the old DC is giving me the same issue, but it died, so I don't care.

Also, the UAC is "off", and I'm running PowerShell as admin. The server is running 2008 R2, and again, I'm copying it to an external HD, specifically a Hitachi drive in a HGST Touro Desk Pro.

Any advice would be great, because I have no clue what else to try here.

  • Not for nothing but Robocopy seems like using a sledge hammer to pound in a thumbtack, as in it being overkill for the job at hand. Have you tried simply copying the file via File Explorer or a command prompt? – joeqwerty Jun 17 '16 at 3:27
  • Yeah, it was saying "1 day left" though. And then it gave an error, and then it restarted the copy. It seemed like it was possibly having the same issue. And on a related note, I just tried doing a VM export to the external drive from the Hyper-V console. And while it obviously didn't say the same error, after running for about 45 minutes it just failed during the export. The Hyper-V-VMMS admin log has this super useful entry: The description for Event ID 18110 from source Microsoft-Windows-Hyper-V-VMMS cannot be found. – Steve Freeman Jun 17 '16 at 4:01
  • I hate to say this but it sound suspiciously like you have a damaged file system at the hyper-v level. I could be wrong though. Try a couple of things. Are you able to rename the vhd file? are you able to execute takeown against the source vhd? Try creating a single text file in the source directory and copy it to the destination as the access denied could be on the dest dir. btw, the syntax above is to copy a whole tree, try a much simpler one: robocopy d:\mx03-dc3012-p50\ \\dstsrv\destdir *.vhd – Ian Murphy Jun 17 '16 at 8:33
  • also, from a speed perspective, better to connect the usb drive to the host, the write performance should be better. Desktops generally don't have very fast ethernet controllers, or IO throughput in general – Ian Murphy Jun 17 '16 at 8:36
  • That's what one of my co-workers thinks as well. He's trying a few other things now (chkdsk among others) to try to repair it enough to be able to copy the vhd off. Other than that, we're going to try to bring the VM back online to copy the files themselves off. If nothing else, we'll have to replicate everything back to that site via DFS...but since it's around 1 TB of data, going over a 2 Mb connection, that's obviously not our first choice.. Also, yeah, the USB drive is connected directly to the host, not to a desktop. – Steve Freeman Jun 17 '16 at 18:46

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.