3

Recently I am facing an issue in Windows Remote Desktop access.

I was able to connect to the machine without any problem till yesterday.

Today, I have opened Remote Desktop Connection and credential popup opened.

I have entered my credential as usual. Once I pressed enter, credentials validated and while entering into machine, it closes automatically.

After some time it shows a dialog with the error message:

Because of a protocol error (code: 0x112f), the remote session will be disconnected.

enter image description here

What is the the problem and how can I solve it?

3

4 Answers 4

3

This error may be triggered by insufficient memory on RDP server. Try to restart server.

1

try this helped me : 1. Logon to the Remote Desktop Services Session Host computer as an administrator 2. Start--Run gpedit.msc 3. In the left pane, under Computer Configuration, navigate to following: Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment 4. In the right pane, double-click on Set compression algorithm for RDP data 5. Select Enabled, and choose Balances memory and network bandwidth 6. Click OK to save the change 1. Logon to the Terminal Services computer as an administrator 2. Start--Run gpedit.msc, click Continue if prompted by UAC 3. In the left pane, under Computer Configuration, navigate to following: Administrative Templates\Windows Components\Terminal Services\Terminal Server\Remote Session Environment 4. In the right pane, double-click on Set compression algorithm for RDP data 5. Select Enabled, and choose Balances memory and network bandwidth 6. Click OK to save the change

Second option : I know it sounds trivial but try to change graphics settings for ex 15bit and most importantly resolution, and let me know.

0

I followed directions from @Michal, but (randomly) found the setting in the screenshot below helped my case.

enter image description here

0

After trying other options to no avail (including computer restart), I found something that worked: in the "display" tab of the remote connection, lower the size of the remote desktop:

lower size of remote desktop

This is less convenient to work this way on the remote server, and I have no clue as to why this happens, but fact is that it worked and I was able to connect to the remote machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.