I just removed Visual Studio 2010 beta 1, and installed the Beta 2 on a win 2008 Web Server.

After performing this, my application pools fails to start. I manually edited the application pools, and selected the new .net 4.0 framework. But when I start the application pool, and request a page in an application in that pool, I get a "HTTP Error 503. The service is unavailable."

If I look at the application pools in IIS, I can see that it has now stopped. Going to the event viewer I find this error message: The worker process failed to pre-load .Net Runtime version v4.0.20506.

Now - there we have the problem. Build no 20506 is the beta 1 version. Beta 2 has build 21006. So for some reason, even though I updated the application pools to use the new installed .NET framework, it still tries to load beta 1.

So where is this setting stored, and how do I change is?

1 Answer 1


Try running aspnet_regiis /i from the 21006 framework folder. That should re-register it with IIS7.

  • Thanks, it worked. Strange, it wasn't necessary to run when I installed the beta 1. Why didn't beta 2 just override that setting, I wonder.
    – Pete
    Oct 27, 2009 at 17:35
  • Great, glad that worked. Beta 2 likely intended to do it but it failed somewhere in the process and just needed a nudge in the right direction. It normally updates the references correctly. Oct 27, 2009 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.