2

I am trying to configure ssmtp to use the namecheap smtp server to send emails. My current configuration:

root=my@email.com
mailhub=mail.privateemail.com:465
rewriteDomain=email.com
hostname=email.com
AuthUser=my@email.com
AuthPass=password
FromLineOverride=YES
UseTLS=NO
UseSTARTTLS=YES

Trying to send a test email using cat - | sudo /usr/sbin/ssmtp -vvvv my@email.com results in the following output in my syslog:

Jun 17 13:55:08 hostname sSMTP[12161]: Creating SSL connection to host
Jun 17 13:55:18 hostname sSMTP[12161]: Invalid response SMTP Server (STARTTLS)
Jun 17 13:55:18 hostname sSMTP[12161]: Cannot open mail.privateemail.com:465

So far, no configuration change has had any impact. I find mostly solutions for gmail, which do not work for Namecheap it seems. The Namecheap documentation does not mention any special settings one needs to apply.

I tried setting it up with gmail and it worked flawlessly. I guess this means that my settings for the NameCheap SMTP are wrong?

3

SSMTP is expected to be TLS from the start. This should work if you set UseTLS to Yes. This port/protocol has been obsoleted now that the STARTTLS option is available.

If you want to use STARTTLS try the submission port (587). I have verified that the submission port is open.

  • It worked. I wonder how you came up with using this (undocumented) port? I am asking because I'd like to be able to troubleshoot such issues on my own in the future! – Sgoettschkes Jun 18 '16 at 7:02
  • 1
    Use of the submission port is standard for authenticated connections. It is documented in the Message Submission RFC tools.ietf.org/html/rfc6409. Port 465 for SSMTP is deprecated see: en.wikipedia.org/wiki/SMTPS. – BillThor Jun 18 '16 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.