0

I can access JBoss 7.1.1 using the URL : http://localhost:9990 and it takes me to the management console window.However, one thing strange I noticed is in the standalone.xml file. As you can see, there is no 9990 port mentioned anywhere inthe XML code below. Here is the excerpt from the file:

<socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
        <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
        <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9090}"/>
        <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
        <socket-binding name="ajp" port="8009"/>
        <socket-binding name="http" port="8080"/>
        <socket-binding name="https" port="8443"/>
        <socket-binding name="osgi-http" interface="management" port="8090"/>
        <socket-binding name="remoting" port="4447"/>
        <socket-binding name="txn-recovery-environment" port="4712"/>
        <socket-binding name="txn-status-manager" port="4713"/>
        <outbound-socket-binding name="mail-smtp">
            <remote-destination host="localhost" port="25"/>
        </outbound-socket-binding>
    </socket-binding-group>

Could anyone tell me why I can still access the jboss with 9990 port and not with 9090 or any other despite the fact that it's not mentioned anywhere in the XML file?

I have jBoss 7.1.1 version installed on Windows 7.

2
  • Perhaps you are using a different configuration (standalone-full.xml, standalone-full-ha.xml, etc) or forgot restart the server after change config. – Federico Sierra Jun 17 '16 at 23:34
  • I didn't actually make any changes in that file as far as I remember right from the start and it still runs only on port 9990. Is there any other place I need to check what's going on? – John Jun 17 '16 at 23:36
0

I would hazard a guess that the value of the 'jboss.management.http.port' property is set somewhere else, either in the start-script you use or standalone.conf. Take a look at the full command line of the server if the value might be set there (-Djboss.management.http.port)

The server.log should output some information on what ports the management interface is binding to, and I believe boot.log might contain the values of some runtime properties.

According to the documentation for 7.1 the default port is 9990 so not sure where 9090 is coming from, might be something left over from AS6, where I believe it was the default?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.