-1

I have installed and configured DRBD on 2 centos nodes and after creating the metadata when i try to start the drbd service, its complaining that the module is not loaded. See below for more details. Any help is appreciated.

[root@nfs-node1 yum.repos.d]# service drbd status drbd not loaded

[root@nfs-node1 yum.repos.d]# drbdadm up clusterdb Could not stat("/proc/drbd"): No such file or directory do you need to load the module? try: modprobe drbd Command 'drbdsetup 0 disk /dev/sda3 /dev/sda3 internal --set-defaults --create-device' terminated with exit code 20 drbdadm attach clusterdb: exited with code 20

[root@nfs-node1 yum.repos.d]# modprobe drbd FATAL: Module drbd not found.

[root@nfs-node1 yum.repos.d]# service drbd start

Starting DRBD resources: Can not load the drbd module.

[root@nfs-node1 yum.repos.d]# uname -a Linux nfs-node1 2.6.32-431.el6.x86_64 #1 SMP Fri Nov 22 03:15:09 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

[root@nfs-node1 yum.repos.d]# rpm -qa | grep drbd kmod-drbd83-8.3.16-3.el6.elrepo.x86_64 drbd83-utils-8.3.16-1.el6.elrepo.x86_64 [root@nfs-node1 yum.repos.d]#

[root@nfs-node1 yum.repos.d]# cat /etc/redhat-release CentOS release 6.8 (Final)

DRBD Configuration:

resource clusterdb { startup { wfc-timeout 30; outdated-wfc-timeout 20; degr-wfc-timeout 30; } net { cram-hmac-alg sha1; shared-secret sync_disk; } syncer { rate 10M; al-extents 257; on-no-data-accessible io-error; } on nfs-node1 { device /dev/drbd0; disk /dev/sda3; address 192.168.1.1:7788; flexible-meta-disk internal; } on nfs-node2 { device /dev/drbd0; disk /dev/sda3; address 192.168.1.2:7788; meta-disk internal; } }

I have done this setup before without any problems. The only thing i'm doing differently here is that there is no network connection between the two nodes yet. I wanted to finish off the configurations first before i make the connections.

Thanks!

0

You don't have the drbd module in your kernel. That is most likely a separate module in your CentOS package manager. So you need to find the kernel module and install it.

  • Thanks for your reply. I did a yum search on that earlier and tried installing the module but it says its already installed and latest. – Syed Quadri Jun 19 '16 at 18:39
  • [root@nfs-node1 yum.repos.d]# yum search drbd | grep kmod-drbd83 kmod-drbd83.x86_64 : drbd83 kernel module(s) [root@nfs-node1 yum.repos.d]# yum install -y kmod-drbd83.x86_64 Loaded plugins: fastestmirror, security Setting up Install Process Loading mirror speeds from cached hostfile * elrepo: muug.ca Package kmod-drbd83-8.3.16-3.el6.elrepo.x86_64 already installed and latest version Nothing to do [root@nfs-node1 yum.repos.d]# – Syed Quadri Jun 19 '16 at 18:41
  • anything else you can think of or can point me to the right place and right module where i can install from? Thank you! – Syed Quadri Jun 19 '16 at 18:42
  • I removed the drbd83 and installed drbd84 now but no luck. Still seeing the same error. – Syed Quadri Jun 19 '16 at 19:03
  • Installed: kmod-drbd84.x86_64 0:8.4.7-1_1.el6.elrepo Dependency Installed: drbd84-utils.x86_64 0:8.9.5-1.el6.elrepo Complete! [root@nfs-node1 yum.repos.d]# [root@nfs-node1 yum.repos.d]# rpm -qa | grep drbd kmod-drbd84-8.4.7-1_1.el6.elrepo.x86_64 drbd84-utils-8.9.5-1.el6.elrepo.x86_64 [root@nfs-node1 yum.repos.d]# modprobe drbd FATAL: Module drbd not found. [root@nfs-node1 yum.repos.d]# service drbd start Can not load the drbd module. [root@nfs-node1 yum.repos.d]# kmod-drbd84.x86_64 – Syed Quadri Jun 19 '16 at 19:04
0

Have you tried to load de module by using modprobe?

modprobe drbd

and adding it to the modules loaded at boot echo drbd > /etc/modules-load.d/drbd.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.